View Issue Details

IDProjectCategoryView StatusLast Update
0037968LazarusPackagespublic2020-10-25 20:43
Reporterserbod Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionno change required 
Product Version2.1 (SVN) 
Summary0037968: package "sparta_Generics" is almost same as "rtl-generics" and can be merged and removed
DescriptionLazarus package:
  lazarus\components\sparta\generics\

is almost same as FPC package
  fpcsrc\packages\rtl-generics

Differences is very few, them can be easily merged and then "sparta_Generics" package will be not need anymore and removed.
Additional InformationDifferences summary:

TCustomAVLTreeMap
+ function AddNodeArray
+ function ExtractNodeArray
+ procedure DeleteArray

TSortedHashSet
+ function PeekPtr


Dependece for:
lazarus\components\sparta\mdi\sparta_mdi.lpk
lazarus\components\sparta\toolsapi\sparta_toolsapi.lpk
lazarus\components\sparta\toolsapi\source\designeditors.pas
lazarus\components\sparta\smartformeditor\source\sparta_componentpalette.pas
lazarus\components\sparta\dockedformeditor\source\sparta_mainide.pas
lazarus\components\sparta\mdi\source\sparta_multiplyresizer.pas
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Juha Manninen

2020-10-22 17:12

developer   ~0126463

Easily merged? Where is the patch to merge it?
Merging is not important because FPC already has Generics.Collections (Sparta origin) in its libs.
The FPC's version is already used when available by Lazarus Sparta packages.
The copy in Lazarus sources will be removed in any case when FPC 3.2 becomes the minimal requirement.
I plan to resolve this as "no change required" unless there is a good reason not to.

Juha Manninen

2020-10-25 20:43

developer   ~0126554

Resolving this one.

Issue History

Date Modified Username Field Change
2020-10-22 16:26 serbod New Issue
2020-10-22 17:12 Juha Manninen Note Added: 0126463
2020-10-22 17:12 Juha Manninen Assigned To => Juha Manninen
2020-10-22 17:12 Juha Manninen Status new => assigned
2020-10-25 20:43 Juha Manninen Status assigned => resolved
2020-10-25 20:43 Juha Manninen Resolution open => no change required
2020-10-25 20:43 Juha Manninen LazTarget => -
2020-10-25 20:43 Juha Manninen Note Added: 0126554