View Issue Details

IDProjectCategoryView StatusLast Update
0037971FPCCompilerpublic2020-10-23 22:00
ReporterReiner Sombrowsky Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.2.0 
Fixed in Version3.3.1 
Summary0037971: Schwerwiegender Fehler im Exception-Handling
DescriptionIm Anhang ein einfaches Project (ohne Binaries), das bei CPU64-Übersetzung nicht korrekt funktioniert
und sogar einen Absturz bringt, bei der mit TaskKill der Prozess gekillt werden muss.
Bei Comilation mit CPU32 funktioniert alles korrekt. Die in Klammern alternative Funktion
arbeitet sowohl bei CPU32 als auch bei CPU64.
Für die Suche des Fehlers brauchte ich eine sehr lange Zeit. Die beiliegende ZIP-Datei
beinhaltet keine Binaries!
Steps To ReproduceÜbersetzung des Lazarus-Projekts mit CPU32 und Ausführung ->Funktion ok
Übersetzung des Lazarus-Projekts mit CPU64 und Ausführung ->Funktion fehlerhaft (eventuell TaskKill notwendig)
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0034772 resolvedSergei Gorelkin Win64 (seh) compiled exe crashes, because implicit finally handler is entered twice. 

Activities

Reiner Sombrowsky

2020-10-23 16:56

reporter  

exception_check.zip (130,725 bytes)

Bart Broersma

2020-10-23 21:12

reporter   ~0126496

AFAIK this is a known bug with 3.2.0: exit in a finally block behaves badly.
IIRC this was fixed in fpc trunk.

Sven Barth

2020-10-23 22:00

manager   ~0126497

There is indeed no error in Trunk anymore.

Considering that implicit finally blocks are involved here as well I assume that this is indeed fixed by the fix of 0034772. Let's hope that we can merge that to 3.2.1...

Also: next time please post bug reports in English. While most of the Core devs do understand German the main language here is English.
And if possible don't have the examples depend on the LCL (though I have to admit that I didn't manage to reproduce it in a smaller example either).

Issue History

Date Modified Username Field Change
2020-10-23 16:56 Reiner Sombrowsky New Issue
2020-10-23 16:56 Reiner Sombrowsky File Added: exception_check.zip
2020-10-23 21:12 Bart Broersma Note Added: 0126496
2020-10-23 22:00 Sven Barth Assigned To => Sven Barth
2020-10-23 22:00 Sven Barth Status new => resolved
2020-10-23 22:00 Sven Barth Resolution open => duplicate
2020-10-23 22:00 Sven Barth Fixed in Version => 3.3.1
2020-10-23 22:00 Sven Barth FPCTarget => -
2020-10-23 22:00 Sven Barth Note Added: 0126497
2020-10-23 22:00 Sven Barth Relationship added duplicate of 0034772