View Issue Details

IDProjectCategoryView StatusLast Update
0037973LazarusIDEpublic2020-10-23 22:26
ReporterPedro Gimeno Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSLinux 
Product Version2.1 (SVN) 
Summary0037973: Some components no longer available, since r64047
DescriptionThere are several components, some quite important such as TDataSource, that have disappeared from the palette and also give an error if used as part of a form, frame, datamodule, etc. of an application (despite this, the application compiles and runs fine).

I've bisected this problem to r64047.

A few components I've found to have disappeared are: TEventLog, TDataSource, TBufDataSet, TCSVDataSet. I don't know how to make an exhaustive list.
TagsNo tags attached.
Fixed in Revisionr64060
LazTarget-
Widgetset
Attached Files

Activities

Juha Manninen

2020-10-23 19:28

developer   ~0126492

Damn, you are right.
r64047 is "IDE: Minor optimization, cleanup and formatting."
It was not supposed to have functional changes. I try to figure out what went wrong...

Juha Manninen

2020-10-23 20:07

developer   ~0126493

Please test with r64060.
I had removed references for units which have initialization sections with package registration.

Pedro Gimeno

2020-10-23 20:55

reporter   ~0126495

Thanks. All of the components that I missed are back. Since I don't know how to make a component list, I can't assure that's all of them.

Juha Manninen

2020-10-23 22:26

developer   ~0126499

Ok, cool. Resolving.

Issue History

Date Modified Username Field Change
2020-10-23 17:33 Pedro Gimeno New Issue
2020-10-23 18:00 Juha Manninen Assigned To => Juha Manninen
2020-10-23 18:00 Juha Manninen Status new => assigned
2020-10-23 19:28 Juha Manninen Note Added: 0126492
2020-10-23 20:07 Juha Manninen Status assigned => feedback
2020-10-23 20:07 Juha Manninen LazTarget => -
2020-10-23 20:07 Juha Manninen Note Added: 0126493
2020-10-23 20:55 Pedro Gimeno Note Added: 0126495
2020-10-23 20:55 Pedro Gimeno Status feedback => assigned
2020-10-23 22:26 Juha Manninen Status assigned => resolved
2020-10-23 22:26 Juha Manninen Resolution open => fixed
2020-10-23 22:26 Juha Manninen Fixed in Revision => r64060
2020-10-23 22:26 Juha Manninen Note Added: 0126499