View Issue Details

IDProjectCategoryView StatusLast Update
0037985LazarusIDEpublic2021-03-03 22:42
ReporterSven Barth Assigned Towp  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionopen 
PlatformX86_64OSWindows NT 
Product Version2.1 (SVN) 
Summary0037985: HighDPI: "Replace next" dialog is not scaled correctly
DescriptionWhen enabling the "Prompt on replace" option of the Replace dialog on a HighDPI system (200%) the dialog that asks whether to replace the next location is scaled to large thus blocking the view of the location to replace (and reaching beyond the screen width in my case).
Additional InformationI have attached two fullscreen (scaled down) screenshot for once (one with HighDPI behavior the other with scaling done by Windows), cause this fully shows where and how the dialog pops up.
TagsNo tags attached.
Fixed in Revisionr64673, r64728
LazTarget2.2
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0037975 closedwp HighDPI: Dots for changed register values not scaled correctly 
related to 0037887 new HighDPI: Icon of component select button not sized correctly 
related to 0032704 resolvedwp OnlinePkgManager hi-dpi bug in messagebox 

Activities

Sven Barth

2020-10-25 12:09

manager  

wp

2021-03-01 11:29

developer   ~0129268

Fixed in 0032704 (r64673)

Sven Barth

2021-03-02 21:25

manager   ~0129331

The buttons are now correct, but the dialog itself is still larger compared with the 100% one and thus blocks the text to replace.

wp

2021-03-03 10:26

developer   ~0129339

Dialog position fixed in r64728.

Sven Barth

2021-03-03 21:22

manager   ~0129365

The dialog is no longer in the way now, but the dialog itself is still significantly larger than with 100% (compare the attached screenshot to the one further up) and in my opinion that shouldn't matter if it's 100% or not...

wp

2021-03-03 22:42

developer   ~0129367

I am attaching two screenshots taken of exactly the same dialog at 96 ppi (100%) and 144 ppi (150%). In my opinion they scale correctly (they look a bit different regarding text position, but this must be due to the icon which does not scale correctly - there is another report about this).

In your screenshot the dialog size appears too large relative to the text. Did you reduce the system font size? (I would not know, though, where this could be done on today's Windows).

Or was your IDE built with LCL scaling turned off?

You seem to use the docked IDE. I have no experience with it personally, so I cannot tell. But there are some reports about scaling issues with it. Could you try to temporarily work with the undocked IDE?
Find_Replace_96ppi.png (4,675 bytes)   
Find_Replace_96ppi.png (4,675 bytes)   
Find_Replace_144ppi.png (6,972 bytes)   
Find_Replace_144ppi.png (6,972 bytes)   

Issue History

Date Modified Username Field Change
2020-10-25 12:09 Sven Barth New Issue
2020-10-25 12:09 Sven Barth File Added: lazarus-highdpi-replace-next-2.png
2020-10-25 12:09 Sven Barth File Added: lazarus-highdpi-replace-next-normal.png
2021-02-28 21:57 Juha Manninen Relationship added related to 0037975
2021-02-28 22:00 Juha Manninen Relationship added related to 0037887
2021-03-01 11:05 wp Assigned To => wp
2021-03-01 11:05 wp Status new => assigned
2021-03-01 11:09 wp Relationship added related to 0032704
2021-03-01 11:29 wp Status assigned => resolved
2021-03-01 11:29 wp Resolution open => no change required
2021-03-01 11:29 wp LazTarget => -
2021-03-01 11:29 wp Widgetset Win32/Win64 => Win32/Win64
2021-03-01 11:29 wp Note Added: 0129268
2021-03-02 21:25 Sven Barth Status resolved => assigned
2021-03-02 21:25 Sven Barth Resolution no change required => open
2021-03-02 21:25 Sven Barth Note Added: 0129331
2021-03-03 10:26 wp Status assigned => resolved
2021-03-03 10:26 wp Resolution open => fixed
2021-03-03 10:26 wp Fixed in Revision => r64673, r64728
2021-03-03 10:26 wp LazTarget - => 2.2
2021-03-03 10:26 wp Widgetset Win32/Win64 => Win32/Win64
2021-03-03 10:26 wp Note Added: 0129339
2021-03-03 21:22 Sven Barth Note Added: 0129365
2021-03-03 21:22 Sven Barth File Added: lazarus-highdpi-replace-next-3.png
2021-03-03 21:22 Sven Barth Status resolved => assigned
2021-03-03 21:22 Sven Barth Resolution fixed => open
2021-03-03 22:42 wp Note Added: 0129367
2021-03-03 22:42 wp File Added: Find_Replace_96ppi.png
2021-03-03 22:42 wp File Added: Find_Replace_144ppi.png