View Issue Details

IDProjectCategoryView StatusLast Update
0037988LazarusLCLpublic2020-11-14 16:50
ReporterGalderius Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Platform32OSWindows 
Product Version2.0.10 
Summary0037988: TComboBox BorderStyle and Align = alClient aren't working.
Description1- If the property BorderStyle is set to bsNone, nothing happens.

2- The property Align = alClient, is actually, alTop.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Bart Broersma

2020-10-26 00:15

developer   ~0126557

IIRC you cannot alter the height of a TComboBox (at least on Windows with Themes enabled), so alClient will look like alTop.
This cannot be changed (the OS won't allow it).

jamie philbrook

2020-10-26 00:30

reporter   ~0126558

Last edited: 2020-10-26 00:31

View 2 revisions

it appears the border style is not implemented for the combobox but just going to the default handler of the TWincontrol.

I believe the intent was not for the border of the combo box drop down or edit box but to draw a line around the base of the control done outside of the combo box..

you can remove the borders on the control, even with themes on. its a process of getting the handle of the edit box and list box to remove the ws_border from the window style.

--- as for the alignment, it is true that it can not align to client due to the fact the edit etc.

 however, if you use a csSimple style of a combo box , that will align to client because it pulls its static list out for view.

wp

2020-10-26 01:28

developer   ~0126559

I think it is a strange idea to client-align a combobox. But if you absolutely must have this you can simulate the effect by setting the Style of the (top- or client-aligned) Combobox to csOwnerDrawFixed and writing an OnResize handler of its parent which sets the Combobox.ItemHeight equal to the parent's ClientHeight.

Bart Broersma

2020-10-30 15:27

developer   ~0126663

The alignment "bug" is not fixable, Windows just won't let you.

Bart Broersma

2020-11-14 16:50

developer   ~0126930

The issue with align is not fixable.
Please open a separate bugreport about the BorderStyle issue.

In the future please only report one bug per report.

Issue History

Date Modified Username Field Change
2020-10-25 19:48 Galderius New Issue
2020-10-26 00:15 Bart Broersma Note Added: 0126557
2020-10-26 00:30 jamie philbrook Note Added: 0126558
2020-10-26 00:31 jamie philbrook Note Edited: 0126558 View Revisions
2020-10-26 01:28 wp Note Added: 0126559
2020-10-30 15:27 Bart Broersma Note Added: 0126663
2020-11-14 16:50 Bart Broersma Assigned To => Bart Broersma
2020-11-14 16:50 Bart Broersma Status new => resolved
2020-11-14 16:50 Bart Broersma Resolution open => not fixable
2020-11-14 16:50 Bart Broersma LazTarget => -
2020-11-14 16:50 Bart Broersma Widgetset Win32/Win64 => Win32/Win64
2020-11-14 16:50 Bart Broersma Note Added: 0126930