View Issue Details

IDProjectCategoryView StatusLast Update
0038064Lazarus CCROtherpublic2021-04-17 01:11
ReporterChristian Ortiz Assigned Towp  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0038064: HighDPI: spktoolbar, in scaled screen
DescriptionLooks different between a normal screen and scaled screen, i attached picures
TagsNo tags attached.
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0037857 closedMartin Friebe Lazarus HighDPI: Small bookmark bullet in editor preview 
related to 0037887 closedJuha Manninen Lazarus HighDPI: Icon of component select button not sized correctly 

Activities

Christian Ortiz

2020-11-11 15:05

reporter  

error.png (78,585 bytes)   
error.png (78,585 bytes)   

wp

2021-03-08 18:28

developer   ~0129510

I cannot confirm this - see attached demo and screenshots at 96ppi (100%) and 144ppi (150%). Did you use LCLScaling correctly? (in the project options check "Use LCL Scaling" and set "DPI awareness" to "on", in the form editor's options check "Force DPI Scaling at design time"). Did you set ImageList.Scaled to true? Did you provide sufficiently large images ( 32x32 for the small, 64x64 for the large images)?

I wonder why the font size is the same in both of your screen shots - the 200% font should be twice as large as the 100% font.

Please post a project in which I can reproduce the issue.
96ppi.png (6,749 bytes)   
96ppi.png (6,749 bytes)   
144.ppi.png (13,773 bytes)   
144.ppi.png (13,773 bytes)   

wp

2021-03-08 18:44

developer   ~0129511

Last edited: 2021-03-08 18:46

View 2 revisions

There was an issue with scaling of fonts modified at designtime. Fixed in r7974. Please test and report back if the fonts in your application still do not change at 200%.

wp

2021-03-08 18:58

developer   ~0129512

This is a demo after r7975. In the top toolbar the fonts are at default, in the bottom toolbar they are changed to Times New Roman/12pt. Scaling is correct. (The memo is for comparison with a control in which the font is known to scale correctly).
spktoolbar_scaling.zip (51,706 bytes)
96ppi-2.png (26,157 bytes)   
96ppi-2.png (26,157 bytes)   
144ppi.png (58,766 bytes)   
144ppi.png (58,766 bytes)   

wp

2021-03-08 19:13

developer   ~0129514

Uploaded an LCLScaling demo to svn (folder spktoolbar/demos/lclscaling).

wp

2021-04-17 01:11

developer   ~0130417

Resolving, no feedback. (Issue seems to be fixed in my own tests).

Issue History

Date Modified Username Field Change
2020-11-11 15:05 Christian Ortiz New Issue
2020-11-11 15:05 Christian Ortiz File Added: error.png
2021-03-08 07:30 Juha Manninen Summary spktoolbar, in scaled screen => HiDPI: spktoolbar, in scaled screen
2021-03-08 07:30 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2021-03-08 08:31 Juha Manninen Summary HiDPI: spktoolbar, in scaled screen => HighDPI: spktoolbar, in scaled screen
2021-03-08 08:31 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2021-03-08 08:32 Juha Manninen Relationship added related to 0037857
2021-03-08 08:33 Juha Manninen Relationship added related to 0037887
2021-03-08 15:44 wp Assigned To => wp
2021-03-08 15:44 wp Status new => assigned
2021-03-08 18:28 wp Note Added: 0129510
2021-03-08 18:28 wp File Added: spktoolbar_scaledimglist.zip
2021-03-08 18:28 wp File Added: 96ppi.png
2021-03-08 18:28 wp File Added: 144.ppi.png
2021-03-08 18:44 wp Note Added: 0129511
2021-03-08 18:45 wp Status assigned => feedback
2021-03-08 18:46 wp Note Edited: 0129511 View Revisions
2021-03-08 18:58 wp Note Added: 0129512
2021-03-08 18:58 wp File Added: spktoolbar_scaling.zip
2021-03-08 18:58 wp File Added: 96ppi-2.png
2021-03-08 18:58 wp File Added: 144ppi.png
2021-03-08 19:13 wp Note Added: 0129514
2021-04-17 01:11 wp Status feedback => resolved
2021-04-17 01:11 wp Resolution open => fixed
2021-04-17 01:11 wp Widgetset Win32/Win64 => Win32/Win64
2021-04-17 01:11 wp Note Added: 0130417