View Issue Details

IDProjectCategoryView StatusLast Update
0038131pas2jstranspilerpublic2020-11-30 12:36
Reporterhenrique Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPas2JsOSWindows 
Summary0038131: Execution error with RTTI
DescriptionThe example I attached is giving execution error "Uncaught TypeError: Cannot read property 'GetElementType' of null".

This is happening because the TArray type is within the "System.pas" unit and not in my unit "UnitError.pas", I guess...
TagsNo tags attached.
Fixed in Revision47614.
Attached Files

Activities

henrique

2020-11-25 12:57

reporter  

Error.zip (715 bytes)

Issue History

Date Modified Username Field Change
2020-11-25 12:57 henrique New Issue
2020-11-25 12:57 henrique File Added: Error.zip
2020-11-25 13:06 Mattias Gaertner Assigned To => Mattias Gaertner
2020-11-25 13:06 Mattias Gaertner Status new => assigned
2020-11-28 12:44 Mattias Gaertner Status assigned => resolved
2020-11-28 12:44 Mattias Gaertner Resolution open => fixed
2020-11-28 12:44 Mattias Gaertner Fixed in Revision => 47614.