View Issue Details

IDProjectCategoryView StatusLast Update
0038140LazarusPackagespublic2021-03-06 12:27
Reportervirgo Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.10 
Summary0038140: fpreport designer: Adding report variables results in error because list is sorted.
DescriptionIn fpreport designer:
When saving variable frmfpreportvariables.TReportVariablesForm.SaveCurrentVariable fails on
LBVariables.Items[FCurrentIndex]:=FCurrentVariable.Name;
because LNVariables is sorted.
Changing it to
    LBVariables.Sorted:= False;
    try
      LBVariables.Items[FCurrentIndex]:=FCurrentVariable.Name;
    finally
      LBVariables.Sorted:= True;
    end;
is sufficient to fix the issue.
TagsNo tags attached.
Fixed in Revisionr64753
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Juha Manninen

2021-03-05 23:34

developer   ~0129416

Fixed, please test.

Issue History

Date Modified Username Field Change
2020-11-27 15:02 virgo New Issue
2021-03-05 23:11 Juha Manninen Assigned To => Juha Manninen
2021-03-05 23:11 Juha Manninen Status new => assigned
2021-03-05 23:34 Juha Manninen Status assigned => resolved
2021-03-05 23:34 Juha Manninen Resolution open => fixed
2021-03-05 23:34 Juha Manninen Fixed in Revision => r64753
2021-03-05 23:34 Juha Manninen LazTarget => -
2021-03-05 23:34 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2021-03-05 23:34 Juha Manninen Note Added: 0129416