View Issue Details

IDProjectCategoryView StatusLast Update
0038210LazarusUtilitiespublic2021-03-16 09:10
ReporterAndrey Zubarev Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionunable to reproduce 
Product Version2.1 (SVN) 
Summary0038210: lazbuild cannot build IDE
Descriptionlazbuild -B -r --build-ide=clean

....skiped....

E:/bin/fpcbinutils/binw32//rm.exe -f
make[1]: Leaving directory 'E:/lazarus/ide'
make: *** No rule to make target 'cleanide ide'. Stop.
make: Leaving directory 'E:/lazarus'
Error: (lazarus) Сборка IDE: stopped with exit code 2
Error: (lazarus) Building IDE: Building IDE failed.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Juha Manninen

2020-12-12 15:49

developer   ~0127563

Did it work with those parameters earlier? What revision broke it?

Andrey Zubarev

2020-12-12 16:03

reporter   ~0127564

I can't answer. I just now needed this

Juha Manninen

2020-12-12 23:47

developer   ~0127580

I get:
 Error: (11006) Illegal parameter: clean

Leave "clean" out and it works.
 $ ./lazbuild -B -r --build-ide=

Tested with Manjaro Linux 64-bit.

Andrey Zubarev

2020-12-13 10:46

reporter   ~0127583

I test on trunk win32
>lazbuild -B -r --build-ide=clean
does not swear at the wrong parameter, does not build

try
>lazbuild -B -r --build-ide=
same result
E:/bin/fpcbinutils/binw32//rm.exe -f
make[1]: Leaving directory 'E:/lazarus/ide'
make: *** No rule to make target 'cleanide ide'. Stop.
make: Leaving directory 'E:/lazarus'
Error: (lazarus) Сборка IDE: stopped with exit code 2
Error: (lazarus) Building IDE: Building IDE failed.

Juha Manninen

2021-02-21 10:34

developer   ~0129053

I tested with a Windows 10 under VirtualBox. I get the same result as on Linux.
 Illegal parameter: clean
Without that parameter it works. In both systems I have FPC 3.2.
Can anybody reproduce the issue? If not, I plan to resolve as "unable to reproduce".

Juha Manninen

2021-03-01 13:04

developer   ~0129279

Resolving.

Andrey Zubarev

2021-03-16 09:10

reporter   ~0129705

Thanks!

Issue History

Date Modified Username Field Change
2020-12-12 15:36 Andrey Zubarev New Issue
2020-12-12 15:49 Juha Manninen Note Added: 0127563
2020-12-12 16:03 Andrey Zubarev Note Added: 0127564
2020-12-12 23:47 Juha Manninen Note Added: 0127580
2020-12-13 10:46 Andrey Zubarev Note Added: 0127583
2021-02-21 10:34 Juha Manninen Assigned To => Juha Manninen
2021-02-21 10:34 Juha Manninen Status new => feedback
2021-02-21 10:34 Juha Manninen LazTarget => -
2021-02-21 10:34 Juha Manninen Note Added: 0129053
2021-03-01 13:04 Juha Manninen Status feedback => resolved
2021-03-01 13:04 Juha Manninen Resolution open => unable to reproduce
2021-03-01 13:04 Juha Manninen Note Added: 0129279
2021-03-16 09:10 Andrey Zubarev Status resolved => closed
2021-03-16 09:10 Andrey Zubarev Note Added: 0129705