View Issue Details

IDProjectCategoryView StatusLast Update
0038219LazarusDebuggerpublic2021-02-15 07:32
Reporterserbod Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1 (SVN) 
Fixed in Version2.2 
Summary0038219: FpDebug - breakpoint with no action cause focus change to IDE
DescriptionFpDebug - when breakpoint with no action reached, IDE get focus for a moment, and tnen return focus back to application. Visually it seems as flickers. GDB not affected.
Steps To Reproduce1. Set breakpoint
2. Open breakpoint properties and disable Break action
3. Run
TagsNo tags attached.
Fixed in Revision64319
LazTarget2.2
Widgetset
Attached Files

Activities

Martin Friebe

2020-12-19 18:14

manager   ~0127697

Should be fixed in r64242.
Please test and close if ok.

Please note: This also affects the history list.
None-breaking breakpoints will no longer create entries, unless they are explicitly set to take a snapshot. (An option to toggle none-snapshot entries for none breaking breakpoints may be added in the future)
https://wiki.lazarus.freepascal.org/IDE_Window:_Debug_History#Automatic_entries_vs_.28User-taken-.29_Snapshots

serbod

2020-12-20 10:30

reporter   ~0127713

Yes, it's works! Now, with Pass Count it become great tool for profiling. Thanks!

serbod

2021-01-03 00:58

reporter   ~0128035

Reopened because in recent build (64318) non-breaking breakpoints on Paint methods cause IDE to hangs, maybe because fast recursive focus change.

Martin Friebe

2021-01-03 02:15

manager   ~0128037

"IDE hang" => Is that Windows or Linux? (64 bit?)

--------------
Can you get a logfile for the hang, please?

lazarus --debug-log=/path/to/yourfiles/laz.log --debug-enable=DBG_CMD_ECHO,DBG_STATE,DBG_DATA_MONITORS,FPDBG_DWARF_ERRORS,FPDBG_DWARF_WARNINGS,FPDBG_DWARF_VERBOSE_LOAD,FPDBG_DWARF_DATA_WARNINGS,DBG_VERBOSE,DBG_WARNINGS,DBG_STATE,DBG_EVENTS,DBG_THREAD_AND_FRAME,DBG_ERRORS,FPDBG_COMMANDS,DBG_BREAKPOINTS,FPDBG_QUEUE

The 2 arguments can also be placed (one per line) into a file called "lazarus.cfg" in the same dir as the lazarus.exe

--------------
And either:
- How to reproduce (small example app)?
- Stacktrace

For a stacktrace, the IDE needs to be debugged itself.
- Open project "ide/lazarus.lpi"
- run (F9)
- in the debugged IDE run your app and get the hang.
- If it is a hidden crash, there is a stack. If not hit "pause" (and then check the threads windows)

Martin Friebe

2021-01-03 02:23

manager   ~0128038

I got lucky and reproduced under Linux. (Questions remain, if you got it under windows)

Martin Friebe

2021-01-03 02:41

manager   ~0128039

I fixed the hang in commit 64319

However under Linux, the stackwindow gets extra updates (lines with address 000000, when the debugger continues to run).
This is more of a cosmetic issue, but ....

So I keep the report open

---
Let me know, if the hang has gone for you to.

Disable or close the stack win, if it is annoying.

serbod

2021-01-04 01:38

reporter   ~0128060

On Win64 works fine

Issue History

Date Modified Username Field Change
2020-12-15 13:47 serbod New Issue
2020-12-15 13:47 serbod Status new => assigned
2020-12-15 13:47 serbod Assigned To => Martin Friebe
2020-12-19 18:14 Martin Friebe Status assigned => resolved
2020-12-19 18:14 Martin Friebe Resolution open => fixed
2020-12-19 18:14 Martin Friebe Fixed in Version => 2.2
2020-12-19 18:14 Martin Friebe LazTarget => 2.2
2020-12-19 18:14 Martin Friebe Note Added: 0127697
2020-12-20 10:30 serbod Status resolved => closed
2020-12-20 10:30 serbod Note Added: 0127713
2021-01-03 00:58 serbod Status closed => assigned
2021-01-03 00:58 serbod Resolution fixed => open
2021-01-03 00:58 serbod Note Added: 0128035
2021-01-03 02:15 Martin Friebe Status assigned => feedback
2021-01-03 02:15 Martin Friebe Note Added: 0128037
2021-01-03 02:23 Martin Friebe Status feedback => assigned
2021-01-03 02:23 Martin Friebe Note Added: 0128038
2021-01-03 02:41 Martin Friebe Note Added: 0128039
2021-01-04 01:38 serbod Note Added: 0128060
2021-02-12 00:37 Martin Friebe Status assigned => resolved
2021-02-12 00:37 Martin Friebe Resolution open => fixed
2021-02-12 00:37 Martin Friebe Fixed in Revision => 64319
2021-02-15 07:32 serbod Status resolved => closed