View Issue Details

IDProjectCategoryView StatusLast Update
0038239LazarusLCLpublic2020-12-22 10:34
Reporterwp Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Summary0038239: Items added to collections via context menu are not displayed in object tree
DescriptionThere are several ways to add items to collection properties, one of them is the possibility to right-click on the collection in the object tree and to select "Add item" from the context menu. This creates a new item in the collection, but the new item is not displayed in the object tree. This used to work in v2.0.10, but no longer in trunk.
Steps To Reproduce- Add a TStatusbar to the form
- Click on the '...' next to the Panels property in the object inspector to open the Panels Editor.
- Click "Add" --> a new item "0 - StatusPanel" appears in the object tree. That's correct.
- But: Select the node "Panels" in the object tree and do a right-click and select "Add item" from the context menu. --> Nothing happens, but when you open the Panels Editor really a new panel has been added.

Other examples are
- TStringList.Columns
- TCoolbar.Bands
- TBufDataset.FieldDefs, .IndexDefs
Additional InformationProbably related to the recent changes of the OI.
TagsNo tags attached.
Fixed in Revisionr64263
LazTarget-
Widgetset
Attached Files

Relationships

related to 0038235 resolvedJuha Manninen Regression, can't delete components placed on a PairSplitter from OI and after many attempts back to locking the IDE again. 
related to 0037434 resolvedJuha Manninen Object Inspector TreeView should not show nodes user has hidden - unless a hidden control is selected. 

Activities

wp

2020-12-20 22:20

developer   ~0127736

The issue is introduced by r64208; r64207 still works correctly.

Juha Manninen

2020-12-22 10:13

developer   ~0127757

Yes, adding a CollectionItem from OI's tree calls TMainIDE.PropHookPersistentAdded.
I had added a wrong assertion there. Basically I just removed it now, although the diff looks big because of indentation change.
Please test.

wp

2020-12-22 10:34

developer   ~0127759

Great! Works fine again.

Issue History

Date Modified Username Field Change
2020-12-20 22:00 wp New Issue
2020-12-20 22:00 wp Status new => assigned
2020-12-20 22:00 wp Assigned To => Juha Manninen
2020-12-20 22:20 wp Note Added: 0127736
2020-12-20 22:20 wp Relationship added related to 0038235
2020-12-20 22:22 wp Relationship added related to 0037434
2020-12-22 10:13 Juha Manninen Status assigned => resolved
2020-12-22 10:13 Juha Manninen Resolution open => fixed
2020-12-22 10:13 Juha Manninen Fixed in Revision => r64263
2020-12-22 10:13 Juha Manninen LazTarget => -
2020-12-22 10:13 Juha Manninen Note Added: 0127757
2020-12-22 10:34 wp Note Added: 0127759
2020-12-22 10:34 wp Status resolved => closed