View Issue Details

IDProjectCategoryView StatusLast Update
0038264LazarusLCLpublic2020-12-29 16:41
ReporterCudaText man_ Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
PlatformLinux x64 
Product Version2.1 (SVN) 
Summary0038264: In ATGroups demo, drag-n-drop mouse cursor is wrong sometimes, STOP cursor
DescriptionRepro:
- install ATFlatControls from https://github.com/alexey-t/atflatcontrols
- run demo_groups from app/ dir
- try to change group-mode via demo's MainMenu (3/4 groups horizontal, vertical) and drag-drop UI tabs from one group to another. sometimes, mouse cursor is STOP while drag-drop is working just after I release mouse btn. so LCL shows STOP cursor wrong.

I add Kazam video to proof this.

TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

CudaText man_

2020-12-27 13:11

reporter  

Bart Broersma

2020-12-27 15:11

developer   ~0127819

Please reproduce the issue in an example that does NOT depend on your own controls.
We are not going to install your ATxxx controls, just to hunt down a bug, we cannot reproduce otherwise.
NB. We've asked you before...

jamie philbrook

2020-12-27 15:20

reporter   ~0127822

That video won't even play over here, BLANK.

no love lost !

I agree with Bart.

Juha Manninen

2020-12-27 15:42

developer   ~0127826

+1
Agree with Bart and Jamie.

CudaText man_

2020-12-28 12:14

reporter   ~0127853

Sorry but it's hard for me to make the simple demo..

Bart Broersma

2020-12-28 16:02

developer   ~0127864

In that case we will resolve this as "unable to reproduce", so you better come up with a sample program that shows the wrong behaviour.

CudaText man_

2020-12-29 10:37

reporter   ~0127889

so you can close this. :(

Bart Broersma

2020-12-29 16:41

developer   ~0127898

Since reporter doesn't want to supply a sample not depending on third party packages...

Issue History

Date Modified Username Field Change
2020-12-27 13:11 CudaText man_ New Issue
2020-12-27 13:11 CudaText man_ File Added: Screencast 2020-12-27 15:01:12.mp4
2020-12-27 15:11 Bart Broersma Status new => feedback
2020-12-27 15:11 Bart Broersma LazTarget => -
2020-12-27 15:11 Bart Broersma Note Added: 0127819
2020-12-27 15:20 jamie philbrook Note Added: 0127822
2020-12-27 15:42 Juha Manninen Note Added: 0127826
2020-12-28 12:14 CudaText man_ Note Added: 0127853
2020-12-28 12:14 CudaText man_ Status feedback => new
2020-12-28 16:02 Bart Broersma Note Added: 0127864
2020-12-29 10:37 CudaText man_ Note Added: 0127889
2020-12-29 16:41 Bart Broersma Assigned To => Bart Broersma
2020-12-29 16:41 Bart Broersma Status new => resolved
2020-12-29 16:41 Bart Broersma Resolution open => unable to reproduce
2020-12-29 16:41 Bart Broersma Widgetset GTK 2 => GTK 2
2020-12-29 16:41 Bart Broersma Note Added: 0127898