View Issue Details

IDProjectCategoryView StatusLast Update
0038271LazarusIDEpublic2021-04-20 23:03
ReporterJesus Reyes Assigned ToMichl  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0038271: Field Editor Window is not dockable, it gets hidden if the IDE compiled with anchordocking
DescriptionWhen the IDE is compiled with the anchordocking design package and the field editor is used, it gets easily hidden behind the main window.
Steps To Reproduce* in a new project drop a TBufDataset on form editor
* doble click it (the fields editor should appear)
* click the editor window

the field editor becomes hidden.
TagsNo tags attached.
Fixed in Revision65034
LazTarget-
Widgetset
Attached Files

Relationships

related to 0019272 closedMichl AchorDocking ignored FormStyle:=fsStayOnTop 
related to 0038779 closedMichl Additional windows are hidden by main IDE window with AnchorDockingDsgn 

Activities

Michl

2021-04-20 23:03

developer   ~0130486

I add the AnchorDocking option FloatingWindowsOnTop in revision 65034. If you check that option, all not docked windows are on top now, at least on Win and GTK2. QT5 fails.

Downside of that option, if you disable it, you have to restart the IDE. For now I don't buffer the original FormStyle. Even if it would set to default e.g. fsNormal, there seems to be a bug in Win - the window stays on top.

Issue History

Date Modified Username Field Change
2020-12-29 00:25 Jesus Reyes New Issue
2021-04-20 18:30 Michl Relationship added related to 0038779
2021-04-20 22:46 Michl Relationship added related to 0019272
2021-04-20 22:46 Michl Assigned To => Michl
2021-04-20 22:46 Michl Status new => assigned
2021-04-20 23:03 Michl Status assigned => resolved
2021-04-20 23:03 Michl Resolution open => fixed
2021-04-20 23:03 Michl Fixed in Revision => 65034
2021-04-20 23:03 Michl LazTarget => -
2021-04-20 23:03 Michl Note Added: 0130486