View Issue Details

IDProjectCategoryView StatusLast Update
0038289FPCCompilerpublic2021-01-03 00:24
ReporterMattias Gaertner Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.0 
Fixed in Version3.3.1 
Summary0038289: Missing syntax error on library exports integer string
Descriptionfpc eats without error the following code:

Steps To Reproducelibrary test;
procedure Test; begin end;
exports
  Test name 3 'abc';
  //------------^^^
end.
Additional InformationExpected: syntax error
TagsNo tags attached.
Fixed in Revision47995
FPCOldBugId
FPCTarget-
Attached Files

Activities

Sven Barth

2021-01-03 00:24

manager   ~0128033

That was a funny one and it could also be triggered with the index clause, though that then failed due to an invalid index so it wasn't as bad...

Anyway, please test and close if okay.

Issue History

Date Modified Username Field Change
2021-01-01 23:40 Mattias Gaertner New Issue
2021-01-01 23:41 Mattias Gaertner Steps to Reproduce Updated View Revisions
2021-01-01 23:41 Mattias Gaertner FPCTarget => -
2021-01-02 18:31 Sven Barth Assigned To => Sven Barth
2021-01-02 18:31 Sven Barth Status new => assigned
2021-01-03 00:24 Sven Barth Status assigned => resolved
2021-01-03 00:24 Sven Barth Resolution open => fixed
2021-01-03 00:24 Sven Barth Fixed in Version => 3.3.1
2021-01-03 00:24 Sven Barth Fixed in Revision => 47995
2021-01-03 00:24 Sven Barth Note Added: 0128033