View Issue Details

IDProjectCategoryView StatusLast Update
0038301LazarusTAChartpublic2021-01-03 18:38
ReporterFrank Moritz Assigned Towp  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSUbuntu 
Summary0038301: Package TAChartLazarusPkg does not compile
DescriptionPackage TAChartLazarusPkg does not compile using fpcupdeluxe, FPC revision 48014 and Lazarus revision 64323

/home/moritz/fpclaz/lazarus/components/tachart/tachartutils.pas(551,47) Error: (4025) Incompatible type for arg no. 3: Got "Double", expected "AnsiString"
Error: (lazarus) Kompiliere Package TAChartLazarusPkg 1.0: stopped with exit code 1
Additional Informationfpcupdeluxe: Performing a SVN/GIT/HG/FTP checkout ... please wait, could take some time.
fpcupdeluxe: info: FPCNativeInstaller (GetModule: FPC): FPC is at revision: 48014
fpcupdeluxe: info: FPC native builder: Detected source version FPC (source): 3.3.1
fpcupdeluxe: info: FPC native builder: Using FPC bootstrap compiler with version: 3.2.0
fpcupdeluxe: Performing a SVN/GIT/HG/FTP checkout ... please wait, could take some time.
fpcupdeluxe: info: LazarusNativeInstaller (GetModule: Lazarus): Lazarus was at revision: unknown
fpcupdeluxe: info: LazarusNativeInstaller (GetModule: Lazarus): Lazarus is now at revision: 64323
fpcupdeluxe: info: Lazarus native builder: Detected source version Lazarus: 2.1.0
fpcupdeluxe: info: Lazarus native builder: Using FPC compiler with version: 3.3.1
fpcupdeluxe: Start of compile error summary.
/home/moritz/fpclaz/lazarus/components/tachart/tachartutils.pas(551,47) Error: (4025) Incompatible type for arg no. 3: Got "Double", expected "AnsiString"
fpcupdeluxe: Start of compile error summary.
tachartutils.pas(1206) Fatal: (10026) There were 1 errors compiling module, stopping
/home/moritz/fpclaz/lazarus/components/tachart/tachartutils.pas(1027,24) Warning: (5093) Function result variable of a managed type does not seem to be initialized
fpcupdeluxe: Start of compile error summary.
Fatal: (1018) Compilation aborted
tachartutils.pas(1206) Fatal: (10026) There were 1 errors compiling module, stopping
fpcupdeluxe: Start of compile error summary.
Error: /home/moritz/fpclaz/fpc/bin/x86_64-linux/ppcx64 returned an error exitcode
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package TAChartLazarusPkg 1.0: stopped with exit code 1
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package fpcunitide 0.1: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package jcfidelazarus 2.0: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package LazDebuggerGdbmi 0.1: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package ChmHelpPkg 0.2.1: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package lazprojectgroups 0.7: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package MemDSLaz 1.2.1: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package ExternHelp 1.3: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package sparta_DockedFormEditor 0.0: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package AnchorDockingDsgn 1.0: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package lazdaemon 0.9.9: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package DateTimeCtrlsDsgn 1.5.1: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package leakview 1.0: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package InstantFPCLaz 1.0: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package SynEdit 1.0: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Kompiliere Package ProjTemplates 1.0: terminated
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) [TLazPackageGraph.CompileRequiredPackages] "Exit code 1"
fpcupdeluxe: Start of compile error summary.
Error: (lazarus) Building IDE: Compile AutoInstall Packages failed.
fpcupdeluxe: Start of compile error summary.
fpcupdeluxe: ERROR: LazarusNativeInstaller (BuildModuleCustom: UserIDE): make returned exit status 0000512
fpcupdeluxe: Done !!
TagsNo tags attached.
Fixed in Revision64324
LazTarget2.2
WidgetsetQT5
Attached Files

Activities

wp

2021-01-03 18:28

developer   ~0128054

Fixed. Probably caused by FPC r48002, will have an impact on some third-party components as well!

Please test and close if OK.

Frank Moritz

2021-01-03 18:38

reporter   ~0128055

Successfull compilation using FPC r48017 and Lazarus r64324

Issue History

Date Modified Username Field Change
2021-01-03 17:56 Frank Moritz New Issue
2021-01-03 18:28 wp Assigned To => wp
2021-01-03 18:28 wp Status new => resolved
2021-01-03 18:28 wp Resolution open => fixed
2021-01-03 18:28 wp Fixed in Revision => 64324
2021-01-03 18:28 wp LazTarget => 2.2
2021-01-03 18:28 wp Widgetset QT5 => QT5
2021-01-03 18:28 wp Note Added: 0128054
2021-01-03 18:38 Frank Moritz Note Added: 0128055