View Issue Details

IDProjectCategoryView StatusLast Update
0038314FPCCompilerpublic2021-02-08 22:06
ReporterC Western Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformAArch64OSDarwin 
Summary0038314: Internal error 200609171 on Darwin for AArch64
Descriptionfpc -gw3 t.pas
Free Pascal Compiler version 3.3.1 [2021/01/05] for aarch64
Copyright (c) 1993-2020 by Florian Klaempfl and others
Target OS: Darwin for AArch64
Compiling t.pas
t.pas(13,1) Fatal: Internal error 200609171
Fatal: Compilation aborted
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0036250 resolvedJonas Maebe Internal error 200609171 

Activities

C Western

2021-01-05 18:04

reporter  

t.pas (231 bytes)   
unit t;
{$mode objfpc}
{$modeswitch advancedrecords}
{$H+}
{$ModeSwitch objectivec2}

interface

implementation

uses MacOSAll;

function NSStringToString(ns: NSString): String;
begin
  Result := '';
end;

end.

t.pas (231 bytes)   

Jonas Maebe

2021-01-05 18:42

manager   ~0128097

I think the error will occur on any Darwin platform with -gw3. I have to admit I've never used -gw3, and I don't know how well it works in general.

C Western

2021-01-05 19:43

reporter   ~0128098

And I find I have reported this previously as 0036250. Could we at least disable -gw3 for this architecture?

Issue History

Date Modified Username Field Change
2021-01-05 18:04 C Western New Issue
2021-01-05 18:04 C Western File Added: t.pas
2021-01-05 18:42 Jonas Maebe Note Added: 0128097
2021-01-05 19:43 C Western Note Added: 0128098
2021-01-05 20:20 J. Gareth Moreton Relationship added related to 0036250
2021-02-08 22:06 Jonas Maebe Assigned To => Jonas Maebe
2021-02-08 22:06 Jonas Maebe Status new => resolved
2021-02-08 22:06 Jonas Maebe Resolution open => duplicate
2021-02-08 22:06 Jonas Maebe FPCTarget => -
2021-02-08 22:06 Jonas Maebe Relationship replaced duplicate of 0036250