View Issue Details

IDProjectCategoryView StatusLast Update
0038327LazarusWidgetsetpublic2021-01-08 23:58
ReporterBen Suttor Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version2.1 (SVN) 
Summary0038327: Gtk2: TLabel: Text is cropped
DescriptionLower parts of p,g,y etc get cropped in 2.1 SVN.

TStaticText works good though.
Steps To ReproducePut TLabel on Form and edit caption. Nothing else changed. AutoSize makes no difference.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0038268 resolvedJuha Manninen In Ubuntu, TLabel is painted cropped for chars 'jy' 

Activities

Ben Suttor

2021-01-07 15:02

reporter  

Label cropped.png (9,960 bytes)   
Label cropped.png (9,960 bytes)   

Ben Suttor

2021-01-08 16:12

reporter   ~0128170

I'm sorry, this bug actually occurs in gtk2, not qt5. I had the wrong setting there when testing this.

Juha Manninen

2021-01-08 17:44

developer   ~0128173

I resolve this as duplicate. Please search for existing reports before creating a new one.

Ben Suttor

2021-01-08 23:58

reporter   ~0128179

Well, it wasn't a duplicate when I thought this was a bug with qt5 ;)

Issue History

Date Modified Username Field Change
2021-01-07 15:02 Ben Suttor New Issue
2021-01-07 15:02 Ben Suttor File Added: Label cropped.png
2021-01-08 16:12 Ben Suttor Note Added: 0128170
2021-01-08 17:40 Juha Manninen Relationship added duplicate of 0038268
2021-01-08 17:41 Juha Manninen Summary Qt5: TLabel: Text is cropped => Gtk2: TLabel: Text is cropped
2021-01-08 17:41 Juha Manninen LazTarget => -
2021-01-08 17:41 Juha Manninen Widgetset QT5 => GTK 2
2021-01-08 17:44 Juha Manninen Assigned To => Juha Manninen
2021-01-08 17:44 Juha Manninen Status new => resolved
2021-01-08 17:44 Juha Manninen Resolution open => duplicate
2021-01-08 17:44 Juha Manninen Widgetset GTK 2 => GTK 2
2021-01-08 17:44 Juha Manninen Note Added: 0128173
2021-01-08 23:58 Ben Suttor Note Added: 0128179