View Issue Details

IDProjectCategoryView StatusLast Update
0038399LazarusLCLpublic2021-02-01 12:26
ReporterAndrea Mauri Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSmacOS 
Product Version2.1 (SVN) 
Summary0038399: opendialog does not select all files
DescriptionIf I have a folder including thousands of files, having an opendialog allowing multiple selection.
I try to load all files (selecting the first one and scrolling till the last one), after selecting the first one I scroll till the last one and "Shift-Click" to select the entire list.
Only a limited number of files is selected by the opendialog (you can check the number shown on the dialog).
It is partially fixed by skalogryz, since now if the opendialog has no filter the opendialog works properly, if I set the opendialog filter property the opendialog fails.


Steps To ReproduceA sample project is attached.
Additional InformationAdditional info can be found on lazarus forum at:
https://forum.lazarus.freepascal.org/index.php/topic,52989.msg391487.html
TagsNo tags attached.
Fixed in Revision64442
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Andrea Mauri

2021-01-26 09:17

reporter  

open_dialog_multiple.zip (131,047 bytes)

Dmitry Boyarintsev

2021-01-30 19:09

developer   ~0128682

the new changes are available in trunk.

you might need to set CocoaUseUTIFilter to true, as shown at:
https://wiki.freepascal.org/Cocoa_Internals/Dialogs#File_Type_Filters

please test and close if ok

Andrea Mauri

2021-02-01 12:26

reporter   ~0128722

Tested on trunk. It works

Issue History

Date Modified Username Field Change
2021-01-26 09:17 Andrea Mauri New Issue
2021-01-26 09:17 Andrea Mauri File Added: open_dialog_multiple.zip
2021-01-30 18:58 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2021-01-30 18:58 Dmitry Boyarintsev Status new => resolved
2021-01-30 18:58 Dmitry Boyarintsev Resolution open => fixed
2021-01-30 18:58 Dmitry Boyarintsev Fixed in Revision => 64442
2021-01-30 18:58 Dmitry Boyarintsev LazTarget => -
2021-01-30 18:58 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2021-01-30 19:09 Dmitry Boyarintsev Note Added: 0128682
2021-02-01 12:26 Andrea Mauri Status resolved => closed
2021-02-01 12:26 Andrea Mauri Note Added: 0128722