View Issue Details

IDProjectCategoryView StatusLast Update
0038422LazarusLCLpublic2021-01-30 12:50
ReporterCudaText man Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1 (SVN) 
Fixed in Version2.2 
Summary0038422: TTabControl fix in r64424 broke the CudaText
DescriptionOnly after return to r64423 I see that CudaText plugins 'favorites' and 'cudaExt' work.
With last update, they broke:
running of plugin gives recursion: screenshot.
TagsNo tags attached.
Fixed in Revision64436
LazTarget2.2
WidgetsetGTK 2, Win32/Win64
Attached Files

Relationships

child of 0038403 resolvedMartin Friebe TTabControl.IndexOfTabAt is always -1, with a hack p.y:=-5 it works 

Activities

CudaText man

2021-01-29 17:19

reporter  

CudaText man

2021-01-29 19:08

reporter   ~0128655

It was caused by a bug in CudaText, so seems LCL is ok (but strange recursion).

Martin Friebe

2021-01-29 19:16

manager   ~0128656

It happens if no handle is allocated yet. I have a fix for the LCL.

There is some more breakage, if components are put inside the tabcontrol.

CudaText man

2021-01-29 19:43

reporter   ~0128657

(please ignore my previous comment)

Martin Friebe

2021-01-29 19:58

manager   ~0128659

Last edited: 2021-01-29 19:58

View 2 revisions

Changed the original fix: See 0038403:0128658

CudaText man

2021-01-29 21:58

reporter   ~0128660

but no update at https://github.com/graemeg/lazarus ?

Issue History

Date Modified Username Field Change
2021-01-29 17:19 CudaText man New Issue
2021-01-29 17:19 CudaText man File Added: Screenshot from 2021-01-29 19-07-33.png
2021-01-29 17:42 Martin Friebe Assigned To => Martin Friebe
2021-01-29 17:42 Martin Friebe Status new => assigned
2021-01-29 19:08 CudaText man Note Added: 0128655
2021-01-29 19:16 Martin Friebe Note Added: 0128656
2021-01-29 19:21 Martin Friebe Relationship added child of 0038403
2021-01-29 19:43 CudaText man Note Added: 0128657
2021-01-29 19:58 Martin Friebe Status assigned => resolved
2021-01-29 19:58 Martin Friebe Resolution open => fixed
2021-01-29 19:58 Martin Friebe Fixed in Version => 2.2
2021-01-29 19:58 Martin Friebe Fixed in Revision => 64436
2021-01-29 19:58 Martin Friebe LazTarget => 2.2
2021-01-29 19:58 Martin Friebe Widgetset GTK 2, Win32/Win64 => GTK 2, Win32/Win64
2021-01-29 19:58 Martin Friebe Note Added: 0128659
2021-01-29 19:58 Martin Friebe Note Edited: 0128659 View Revisions
2021-01-29 21:58 CudaText man Note Added: 0128660
2021-01-30 12:50 CudaText man Status resolved => closed