View Issue Details

IDProjectCategoryView StatusLast Update
0038521LazarusInstallerpublic2021-02-21 12:21
ReporterBram van Vliet Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux GTK2OSXUbuntu 
Product Version2.0.10 
Summary0038521: Building from source from https://svn.freepascal.org/svn/lazarus/tags/lazarus_2_0_10 fails due to missing unit
DescriptionWhen building Lazarus from source retrieved from https://svn.freepascal.org/svn/lazarus/tags/lazarus_2_0_10 building fails with the error below:

/LazStable/fpc/units/x86_64-linux/chm/chmreader.ppu:chmreader.pas(80,12) Fatal: (10022) Can't find unit chmreader used by ChmLangRef
Steps To ReproduceDo a "clean" install in a empty folder with fpcupdeluxe selecting "stable" for both fpc and lazarus.
Additional Informationfpcupdeluxe: info: LazarusNativeInstaller (GetModule: Lazarus): Lazarus is at revision: 63526
fpcupdeluxe: info: Lazarus native builder: Detected source version Lazarus: 2.0.10
fpcupdeluxe: info: Lazarus native builder: Using FPC compiler with version: 3.2.0
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Mattias Gaertner

2021-02-21 00:05

manager   ~0129041

The tags/lazarus_2_0_10 has not changed since 2020-07-05 and it builds clean without fpcupdelux.
Looks like something has changed in fpcupdelux or you have a misconfiguration on your system.
fpcupdelux is neither maintained by Lazarus nor fpc.
 
Maybe better ask the fpcupdelux maintainer.

Bram van Vliet

2021-02-21 12:14

reporter   ~0129055

Will do.

Just checked again on XUbuntu 20.04 64bit Linux and now it's ok. Please mark as solved / closed.

Thanks.

Issue History

Date Modified Username Field Change
2021-02-20 23:18 Bram van Vliet New Issue
2021-02-20 23:57 Mattias Gaertner Assigned To => Mattias Gaertner
2021-02-20 23:57 Mattias Gaertner Status new => assigned
2021-02-21 00:05 Mattias Gaertner Status assigned => feedback
2021-02-21 00:05 Mattias Gaertner LazTarget => -
2021-02-21 00:05 Mattias Gaertner Note Added: 0129041
2021-02-21 12:14 Bram van Vliet Note Added: 0129055
2021-02-21 12:14 Bram van Vliet Status feedback => assigned
2021-02-21 12:21 Mattias Gaertner Status assigned => resolved
2021-02-21 12:21 Mattias Gaertner Resolution open => fixed
2021-02-21 12:21 Mattias Gaertner Widgetset GTK 2 => GTK 2