View Issue Details

IDProjectCategoryView StatusLast Update
0038545FPCCompilerpublic2021-02-25 20:46
ReporterMartin Friebe Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformMacOSBigSur 
Product Version3.2.0 
Summary0038545: Dwarf-3 / MacOs, Internal Error 200609171 / Fpc 3.2.0 / 64bit
DescriptionI get an Internal Error 200609171 on Mac. (Same Code / Same Settings works on other OS)

If I change debug info from Dwarf-3 to Dwarf2-with-sets, then the error goes away.

Here is the code in question:
https://github.com/User4martin/CEF4Delphi/tree/f-compiler-error-mac

It happens in unit eCEFWinControl
line 119


Unfortunately I will not be able to test with any other FPC version.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0036250 resolvedJonas Maebe Internal error 200609171 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2021-02-25 20:43 Martin Friebe New Issue
2021-02-25 20:46 Jonas Maebe Assigned To => Jonas Maebe
2021-02-25 20:46 Jonas Maebe Status new => resolved
2021-02-25 20:46 Jonas Maebe Resolution open => duplicate
2021-02-25 20:46 Jonas Maebe FPCTarget => -
2021-02-25 20:46 Jonas Maebe Relationship added duplicate of 0036250