View Issue Details

IDProjectCategoryView StatusLast Update
0038582LazarusIDEpublic2021-03-06 22:34
ReporterTrevor Roydhouse Assigned ToBart Broersma  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformApple aarch64OSmacOS 
Product Version2.1 (SVN) 
Summary0038582: [macOS aarch64] Lazarus BIGIDE executable dies on startup
DescriptionLazarus executable built with BIGIDE option dies on startup:

trev@macmini8 [/Users/trev/laz_trunk] $ ./lazarus
[FORMS.PP] ExceptionOccurred
  Sender=EReadError
  Exception=Error reading MainDM.Height: Access violation
  Stack trace:
  $00000001023D47E4
  $00000001023C8388
  $00000001023CA440
  $00000001023D5478
  $00000001024A2FC4
  $00000001024A2D3C
  $0000000102499C30
  $00000001023CCEAC
  $00000001023C9A7C
  $00000001034D1C88
TApplication.HandleException: EReadError
Error reading MainDM.Height: Access violation
  Stack trace:
  $00000001023D47E4
  $00000001023C8388
  $00000001023CA440
  $00000001023D5478
  $00000001024A2FC4
  $00000001024A2D3C
  $0000000102499C30
  $00000001023CCEAC
  $00000001023C9A7C
  $00000001034D1C88
Exception at 00000001023D47E4: EReadError:
Error reading MainDM.Height: Access violation.

(lldb) r
Process 21339 launched: '/Users/trev/laz_trunk/lazarus' (arm64)
Process 21339 stopped
* thread 0000001, queue = 'com.apple.main-thread', stop reason = EXC_BAD_ACCESS (code=1, address=0x70)
    frame #0: 0x000000010010a198 lazarus`CLASSES$_$TDATAMODULE_$__$$_DEFINEPROPERTIES$TFILER + 120
lazarus`CLASSES$_$TDATAMODULE_$__$$_DEFINEPROPERTIES$TFILER:
-> 0x10010a198 <+120>: ldr w2, [x0, #0x70]
    0x10010a19c <+124>: cmp w2, w1
    0x10010a1a0 <+128>: cset w2, ne
    0x10010a1a4 <+132>: cmp w1, #0x60 ; =0x60
Target 0: (lazarus) stopped.
Steps To Reproducemake distclean all LCL_PLATFORM=cocoa CPU_TARGET=aarch64 bigide
Tagsaarch64, BIGIDE, MacOS
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0038576 resolvedFlorian FPC Cannot use TDataModule (Lazarus Revision: 64727, FPC Revision: 48871) 
has duplicate 0038588 resolvedJuha Manninen Lazarus Crash when saving DataModule 

Activities

Trevor Roydhouse

2021-03-05 03:59

reporter   ~0129387

I should add that building a "normal" IDE has no startup issues.

Juha Manninen

2021-03-05 07:31

developer   ~0129389

Do you build with FPC trunk?
Then according to 0038576 it is caused by a new optimization in FPC.

Trevor Roydhouse

2021-03-05 09:21

reporter   ~0129393

Yes. Please close, I've moved to the earlier report.

Trevor Roydhouse

2021-03-06 22:34

reporter   ~0129454

Dupe.

Issue History

Date Modified Username Field Change
2021-03-05 03:53 Trevor Roydhouse New Issue
2021-03-05 03:59 Trevor Roydhouse Note Added: 0129387
2021-03-05 04:01 Trevor Roydhouse Tag Attached: aarch64
2021-03-05 04:01 Trevor Roydhouse Tag Attached: MacOS
2021-03-05 04:01 Trevor Roydhouse Tag Attached: BIGIDE
2021-03-05 07:25 Juha Manninen Relationship added duplicate of 0038576
2021-03-05 07:31 Juha Manninen Note Added: 0129389
2021-03-05 09:21 Trevor Roydhouse Note Added: 0129393
2021-03-05 13:40 Bart Broersma Assigned To => Bart Broersma
2021-03-05 13:40 Bart Broersma Status new => resolved
2021-03-05 13:40 Bart Broersma Resolution open => duplicate
2021-03-05 13:40 Bart Broersma LazTarget => -
2021-03-05 18:38 Juha Manninen Relationship added has duplicate 0038588
2021-03-06 22:34 Trevor Roydhouse Status resolved => closed
2021-03-06 22:34 Trevor Roydhouse Note Added: 0129454