View Issue Details

IDProjectCategoryView StatusLast Update
0038588LazarusIDEpublic2021-03-06 10:57
ReporterMartok Assigned ToJuha Manninen  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
Summary0038588: Crash when saving DataModule
DescriptionSaving TDataModule descendants is completely broken.

[Window Title]
Streaming-Fehler

[Content]
Kann DataModule3 nicht streamen: TDataModule3
Access violation

Pfad zur fehlgeschlagenen Instanz:
TDataModule3


Seems to be a component streaming issue (in that case, please move this report to Compiler/RTL), but there is some corruption involved and I can't get breakpoints to work when debugging the IDE, so I can't confirm what side the problem is on.

Lazarus trunk r64727
FPC trunk r48870
Steps To Reproduce1. Create a Datamodule: File -> New -> Datamodule
2. Try to save it
Additional Information(line numbers are displayed in the stack trace dialog, but for some reason don't get copied...)

#0 CLASSES$_$TDATAMODULE_$__$$_DEFINEPROPERTIES$TFILER at dm.inc:88
0000001 CLASSES$_$TWRITER_$__$$_WRITEPROPERTIES$TPERSISTENT at writer.inc:841
0000002 CLASSES$_$TWRITER_$__$$_WRITECOMPONENTDATA$TCOMPONENT at writer.inc:747
0000003 CLASSES$_$TCOMPONENT_$__$$_WRITESTATE$TWRITER at :0
0000004 CLASSES$_$TWRITER_$__$$_WRITECOMPONENT$TCOMPONENT at :0
0000005 CLASSES$_$TWRITER_$__$$_WRITEDESCENDENT$TCOMPONENT$TCOMPONENT at :0
0000006 SAVEUNITCOMPONENT(0x13c3dde8, 0x0, 0x0, [SFSAVEAS, SFCHECKAMBIGUOUSFILES]) at sourcefilemanager.pas:5096
0000007 SAVEEDITORFILE(0x14568588, [SFSAVEAS, SFCHECKAMBIGUOUSFILES]) at sourcefilemanager.pas:2556
0000008 DOSAVEEDITORFILE(0x12213ba0, 0x14568588, [SFCHECKAMBIGUOUSFILES]) at main.pp:5719
0000009 MNUSAVECLICKED(0x12213ba0, 0x174525d0) at main.pp:3332
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0038582 closedBart Broersma Lazarus [macOS aarch64] Lazarus BIGIDE executable dies on startup 
duplicate of 0038576 resolvedFlorian FPC Cannot use TDataModule (Lazarus Revision: 64727, FPC Revision: 48871) 

Activities

Juha Manninen

2021-03-05 18:40

developer   ~0129401

Please don't create duplicate reports.

Martok

2021-03-05 20:30

reporter   ~0129408

I've searched for "TDataModule" and "DataModule" before creating this report. You'll find that the related report consistently misspells the class name, hence, is invisble to search.

Can close this one then, thanks for locating the other one.

Juha Manninen

2021-03-06 10:57

developer   ~0129426

Resolving...

Issue History

Date Modified Username Field Change
2021-03-05 17:34 Martok New Issue
2021-03-05 18:38 Juha Manninen Relationship added duplicate of 0038582
2021-03-05 18:39 Juha Manninen Relationship added duplicate of 0038576
2021-03-05 18:40 Juha Manninen Note Added: 0129401
2021-03-05 20:30 Martok Note Added: 0129408
2021-03-06 10:57 Juha Manninen Assigned To => Juha Manninen
2021-03-06 10:57 Juha Manninen Status new => resolved
2021-03-06 10:57 Juha Manninen Resolution open => duplicate
2021-03-06 10:57 Juha Manninen LazTarget => -
2021-03-06 10:57 Juha Manninen Note Added: 0129426