View Issue Details

IDProjectCategoryView StatusLast Update
0038679FPCCompilerpublic2021-04-20 16:46
ReporterErich Eckner Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformlinuxOSarch linux 
Product Version3.3.1 
Summary0038679: calls wrong overloaded function if difference is only in type of pointer to specialized class
DescriptionThe wrong overloaded function is being called, when they differ only in type of pointer to a specialized class. It doesn't help to explicitly cast to the correct pointer type, either.
This leads to the given pointer being treated as the wrong type, which leads to all kind of bad behavior (this is the actual issue, I was trying to bisect, first).
Steps To Reproducetake the attached program and do:

> fpc -MObjFPC mwe.pas
> ./mwe

It claims to run the copy_from(a: pArraySingle) method, although, it should run copy_from(a: pArrayDouble).
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0038680 new wrong overloaded method is chosen, when they differ only in pointer to specialized class 

Activities

Sven Barth

2021-03-29 13:02

manager   ~0129975

Can it be that you forgot to attach your example program? :)

Erich Eckner

2021-04-20 10:39

reporter   ~0130472

yes, apparently, instead of attaching the file, I opened a new bug >.<
Please close this bug, here.

Issue History

Date Modified Username Field Change
2021-03-29 09:55 Erich Eckner New Issue
2021-03-29 13:02 Sven Barth Assigned To => Sven Barth
2021-03-29 13:02 Sven Barth Status new => feedback
2021-03-29 13:02 Sven Barth FPCTarget => -
2021-03-29 13:02 Sven Barth Note Added: 0129975
2021-04-20 10:39 Erich Eckner Note Added: 0130472
2021-04-20 10:39 Erich Eckner Status feedback => assigned
2021-04-20 16:46 Sven Barth Status assigned => resolved
2021-04-20 16:46 Sven Barth Resolution open => duplicate
2021-04-20 16:46 Sven Barth Relationship added duplicate of 0038680