View Issue Details

IDProjectCategoryView StatusLast Update
0038722pas2jstranspilerpublic2021-04-08 15:48
Reporterhenrique Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformPas2JsOSWindows 
Summary0038722: Duplicate identifier.
DescriptionWhen I try to declare more than one generic reference to a procedure, which has the same name but different quantity generic parameters, you are erroring "Error: Duplicate identifier "TProc" at UnitError.pas(8,8)".

In the attached example, you have the declaration of a procedure with the same name, but that is not generic.

This is to leave the statements of SysUtils, equal to those that exist in Delphi today.
TagsNo tags attached.
Fixed in Revision
Attached Files

Activities

henrique

2021-04-07 21:16

reporter  

Error.zip (516 bytes)

Mattias Gaertner

2021-04-08 15:48

manager   ~0130174

Delphi like overloads T<A>, T<A,B>, etc are not yet supported. See:
https://wiki.freepascal.org/pas2js_Generics#ToDos

Since this feature request is already in the todo list, no need to keep the request in two places, so I set it here to resolved.

Issue History

Date Modified Username Field Change
2021-04-07 21:16 henrique New Issue
2021-04-07 21:16 henrique File Added: Error.zip
2021-04-07 22:22 Mattias Gaertner Assigned To => Mattias Gaertner
2021-04-07 22:22 Mattias Gaertner Status new => assigned
2021-04-08 15:48 Mattias Gaertner Status assigned => resolved
2021-04-08 15:48 Mattias Gaertner Resolution open => no change required
2021-04-08 15:48 Mattias Gaertner Note Added: 0130174