View Issue Details

IDProjectCategoryView StatusLast Update
0038727FPCCompilerpublic2021-04-12 09:55
ReporterKarl-Michael Schindler Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformdarwinOSMac OS X 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0038727: svn revision 49129 breaks crossbuilding powerpc(64)-* targets
Descriptionsvn revision 49129 breaks crossbuilding powerpc-linux, powerpc-netbsd and powerpc64-linux targets. Error message from powerpc-linux:

...
powerpc-linux-as -a32 -o /BlaBla/FreePascal/rtl/units/powerpc-linux/gprt0.o powerpc/gprt0.as
/BlaBla/FreePascal/compiler/ppcrossppc -Ur -Tlinux -Ppowerpc -XPpowerpc-linux- -Ur -Xs -O2 -n -Fi../inc -Fi../powerpc -Fi../unix -Fipowerpc -FE. -FU/BlaBla/FreePascal/rtl/units/powerpc-linux -ap -dpowerpc -dRELEASE -Us -Sg system.pp
sysos.inc(47,1) Fatal: Internal error 2016012401
Fatal: Compilation aborted
make[5]: *** [system.ppu] Error 1
make[4]: *** [linux_all] Error 2
make[3]: *** [rtl] Error 2
make[2]: *** [cycle] Error 2
make[1]: *** [compiler_cycle] Error 2
make: *** [build-stamp.powerpc-linux] Error 2
Steps To Reproducesvn up -r 49129
make all OPT=-ap OS_TARGET=linux CPU_TARGET=powerpc

correspondingly for powerpc-netbsd and powerpc64-linux.
Additional InformationI assume that powerpc-darwin is also affected, because it might use bsd/sysos.inc like netbsd.

I do not think that this should matter, but for the sake of completeness:

macOS: 11.2.3
Xcode: 12.4
Bootstrap fpc compiler: fpc 3.2.0 installed using fink

I also checked other linux cross targets. Other cpu targets do not show this error, it is powerpc(64) only. Further tests are ongoing.
TagsNo tags attached.
Fixed in Revision49180
FPCOldBugId
FPCTarget-
Attached Files

Activities

Karl-Michael Schindler

2021-04-08 17:13

reporter   ~0130179

Last edited: 2021-04-08 17:40

View 2 revisions

xtensa-linux is also affected, but fixed in svn revision 49132.

Karl-Michael Schindler

2021-04-10 19:53

reporter   ~0130246

Last edited: 2021-04-10 23:17

View 2 revisions

Fixed fo powerpc by commit 49153. Still an issue for powerpc64.

Karl-Michael Schindler

2021-04-12 09:13

reporter   ~0130299

49180 finally fixes also powerpc64. Issue is resolved. Thanks.

Sven Barth

2021-04-12 09:36

manager   ~0130302

Thank you for checking. Please close.

Karl-Michael Schindler

2021-04-12 09:55

reporter   ~0130303

Nice job :-)

Issue History

Date Modified Username Field Change
2021-04-08 14:18 Karl-Michael Schindler New Issue
2021-04-08 17:13 Karl-Michael Schindler Note Added: 0130179
2021-04-08 17:40 Karl-Michael Schindler Note Edited: 0130179 View Revisions
2021-04-10 19:53 Karl-Michael Schindler Note Added: 0130246
2021-04-10 23:17 Karl-Michael Schindler Note Edited: 0130246 View Revisions
2021-04-12 09:13 Karl-Michael Schindler Note Added: 0130299
2021-04-12 09:36 Sven Barth Assigned To => Sven Barth
2021-04-12 09:36 Sven Barth Status new => resolved
2021-04-12 09:36 Sven Barth Resolution open => fixed
2021-04-12 09:36 Sven Barth Fixed in Version => 3.3.1
2021-04-12 09:36 Sven Barth Fixed in Revision => 49180
2021-04-12 09:36 Sven Barth FPCTarget => -
2021-04-12 09:36 Sven Barth Note Added: 0130302
2021-04-12 09:55 Karl-Michael Schindler Status resolved => closed
2021-04-12 09:55 Karl-Michael Schindler Note Added: 0130303