View Issue Details

IDProjectCategoryView StatusLast Update
0038737PackagesPackagespublic2021-04-21 14:40
ReporterBi0T1N Assigned ToMichl  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Summary0038737: Artifact of form on bottom left with AnchorDockingDsgn
DescriptionI don't know how to describe it properly thus some screenshots :)

https://wiki.lazarus.freepascal.org/File:Laz_IDE_v1.2.6_Docked.png
https://wiki.lazarus.freepascal.org/File:Lazarus_IDE_v1.8.4_docked.png
https://wiki.lazarus.freepascal.org/File:docking_headers.gif
Additional InformationThis prevents the properties window from being dragged further down
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0038740 closedMichl Lazarus Status bar text not updated if information box is disabled 

Activities

Bi0T1N

2021-04-10 22:55

reporter  

lazarus_docked_ide.jpg (1,312,400 bytes)

wp

2021-04-10 23:57

developer   ~0130259

Last edited: 2021-04-10 23:58

View 2 revisions

Isn't this the info box? Right-click on the object inspector and uncheck "Show Information Box". And there is also a status bar in the OI which you may want to disable via context menu as well.

Bi0T1N

2021-04-11 14:25

reporter   ~0130269

Last edited: 2021-04-11 14:27

View 2 revisions

Thanks, it's actually the status bar. The info box is the one above. However, would've expected that also the bottom line of the status bar is visible so that it's clear that it's not something unintended placed there.
By the way, if you deactivate the info box the status bar is no longer updated - is this intended?
lazarus_docked_ide_infobox.PNG (89,993 bytes)   
lazarus_docked_ide_infobox.PNG (89,993 bytes)   

wp

2021-04-11 15:53

developer   ~0130270

> However, would've expected that also the bottom line of the status bar is visible so that it's clear that it's not something unintended placed there.
I can't say anything about the docked IDE which I do not use. But on the undocked IDE the bottom line of the status bar is visible, as well as the gripper at the bottom/right.

> if you deactivate the info box the status bar is no longer updated - is this intended?
I don't think so, otherwise it would be useless. I can reproduce this on my undocked IDE (Win 10).

Bi0T1N

2021-04-11 22:28

reporter   ~0130292

> if you deactivate the info box the status bar is no longer updated - is this intended?
> I don't think so, otherwise it would be useless. I can reproduce this on my undocked IDE (Win 10).
Reported as new bug in 0038740

Michl

2021-04-12 21:01

developer   ~0130323

So nothing to change here?

Bi0T1N

2021-04-13 11:03

reporter   ~0130339

Last edited: 2021-04-13 11:04

View 2 revisions

Guess so, it just looks a bit odd compared to the undocked IDE because of the right line. Thought it is an unintended form placed there.
lazarus_undocked_ide.PNG (77,450 bytes)   
lazarus_undocked_ide.PNG (77,450 bytes)   

Issue History

Date Modified Username Field Change
2021-04-10 22:55 Bi0T1N New Issue
2021-04-10 22:55 Bi0T1N File Added: lazarus_docked_ide.jpg
2021-04-10 23:57 wp Note Added: 0130259
2021-04-10 23:58 wp Note Edited: 0130259 View Revisions
2021-04-11 14:25 Bi0T1N Note Added: 0130269
2021-04-11 14:25 Bi0T1N File Added: lazarus_docked_ide_infobox.PNG
2021-04-11 14:25 Bi0T1N File Added: lazarus_docked_ide_status_box_not_updated.PNG
2021-04-11 14:27 Bi0T1N Note Edited: 0130269 View Revisions
2021-04-11 15:53 wp Note Added: 0130270
2021-04-11 22:28 Bi0T1N Note Added: 0130292
2021-04-12 21:01 Michl Assigned To => Michl
2021-04-12 21:01 Michl Status new => feedback
2021-04-12 21:01 Michl LazTarget => -
2021-04-12 21:01 Michl Note Added: 0130323
2021-04-12 21:02 Michl Relationship added related to 0034740
2021-04-12 21:02 Michl Relationship deleted related to 0034740
2021-04-12 21:03 Michl Relationship added related to 0038740
2021-04-13 11:03 Bi0T1N Note Added: 0130339
2021-04-13 11:03 Bi0T1N File Added: lazarus_undocked_ide.PNG
2021-04-13 11:03 Bi0T1N Status feedback => assigned
2021-04-13 11:04 Bi0T1N Note Edited: 0130339 View Revisions
2021-04-20 23:14 Michl Status assigned => resolved
2021-04-20 23:14 Michl Resolution open => no change required
2021-04-20 23:14 Michl Widgetset Win32/Win64 => Win32/Win64
2021-04-21 14:40 Bi0T1N Status resolved => closed