View Issue Details

IDProjectCategoryView StatusLast Update
0038745LazarusIDEpublic2021-04-17 14:12
ReporterCudaText man Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
OSUbuntu 20.04 
Product Version2.1 (SVN) 
Summary0038745: IDE in last revisions cannot "find references" to an method name
DescriptionIn last week or two, I cannot anymore find usages of a method name in TFrame (TFrame is used in the main form).
I position caret in 2 ways: in method declaration in TFrame class, or in method implementation in that class.
Both now find only 2 references: these 2 references in TFrame, but the cannot find ref's to that method in the main form.

Lazarus 2.1.0 r64977 FPC 3.2.1 x86_64-linux-gtk2

I see that UI is changed a little: dialog "Find references" now DISABLED the radio button "in the whole project" and check the radiobutton "in current unit". maybe because of that "in current unit" I got results in current unit.

TagsNo tags attached.
Fixed in Revision65010.
LazTarget-
Widgetset
Attached Files

Relationships

has duplicate 0038746 closedMattias Gaertner IDE in last revisions cannot "find references" to an method name 

Activities

CudaText man

2021-04-12 18:40

reporter  

CudaText man

2021-04-14 10:47

reporter   ~0130370

Last edited: 2021-04-14 10:48

View 3 revisions

How to reproduce it.

- download project CudaText ( https://github.com/Alexey-T/CudaText/ )
- open unit formframe.pas, place caret on
    procedure DoFileOpen(const AFileName, AFileName2.....

- call "Find references", check item "In main project" (or "In all projects"), OK-- it finds only 2 ref's (declaration+implementation), missing all ref's from the fmMain.pas

Issue History

Date Modified Username Field Change
2021-04-12 18:40 CudaText man New Issue
2021-04-12 18:40 CudaText man File Added: Screenshot from 2021-04-12 19-34-24.png
2021-04-12 18:51 Bart Broersma Relationship added has duplicate 0038746
2021-04-14 10:47 CudaText man Note Added: 0130370
2021-04-14 10:48 CudaText man Note Edited: 0130370 View Revisions
2021-04-14 10:48 CudaText man Note Edited: 0130370 View Revisions
2021-04-14 19:23 Mattias Gaertner Assigned To => Mattias Gaertner
2021-04-14 19:23 Mattias Gaertner Status new => assigned
2021-04-17 13:22 Mattias Gaertner Status assigned => resolved
2021-04-17 13:22 Mattias Gaertner Resolution open => fixed
2021-04-17 13:22 Mattias Gaertner Fixed in Revision => 65010.
2021-04-17 13:22 Mattias Gaertner LazTarget => -
2021-04-17 14:12 CudaText man Status resolved => closed