View Issue Details

IDProjectCategoryView StatusLast Update
0038750FPCRTLpublic2021-04-13 20:33
Reporterekryukov Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.2.1 
Summary0038750: SysInitFPU set FPU exceptions ignoring Math's ExceptionMask (AARCH64)
Descriptionaarch64.inc:SysInitFPU resets FPU exceptions flags and ignores ExceptionMask from math.

Here is a code:
..
    { enable invalid operations and division by zero exceptions. }
    setfpcr(((getfpcr and not(fpu_exception_mask)) or fpu_dze or fpu_ofe or fpu_ioe));
..

So, if we call SetExceptionMask and then new thread started, SysInitFPU resets "fpcr" register by enabling invalid operations and division by zero exceptions.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0038230 new Exception in system functions on Apple M1 

Activities

ekryukov

2021-04-13 15:22

reporter   ~0130344

Attached a simple test example
fpsr_test.zip (2,183 bytes)

Issue History

Date Modified Username Field Change
2021-04-13 12:24 ekryukov New Issue
2021-04-13 15:22 ekryukov Note Added: 0130344
2021-04-13 15:22 ekryukov File Added: fpsr_test.zip
2021-04-13 20:33 Jonas Maebe Assigned To => Jonas Maebe
2021-04-13 20:33 Jonas Maebe Status new => resolved
2021-04-13 20:33 Jonas Maebe Resolution open => duplicate
2021-04-13 20:33 Jonas Maebe FPCTarget => -
2021-04-13 20:33 Jonas Maebe Relationship added duplicate of 0038230