View Issue Details

IDProjectCategoryView StatusLast Update
0038757LazarusIDEpublic2021-04-15 22:06
ReporterBi0T1N Assigned ToMartin Friebe  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Summary0038757: Compilation fails because lisDebugOptionsFrmEditClass and lisDebugOptionsFrmEditClassWarn identifiers are not defined
DescriptionThe identifiers are not defined in lazarusidestrconsts.pas, see links below.

Version: trunk@64997

fpcupdeluxe output:
(3104) Compiling lazarus\debugger\frames\debugger_class_options.pas
lazarus\debugger\frames\debugger_class_options.pas(647,27) Error: (5000) Identifier not found "lisDebugOptionsFrmEditClass"
lazarus\debugger\frames\debugger_class_options.pas(648,33) Error: (5000) Identifier not found "lisDebugOptionsFrmEditClassWarn"
debugger_class_options.pas(717) Fatal: (10026) There were 2 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Additional Informationhttps://github.com/graemeg/lazarus/blob/upstream/debugger/frames/debugger_class_options.pas#L647
https://github.com/graemeg/lazarus/blob/upstream/ide/lazarusidestrconsts.pas#L5402
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Bi0T1N

2021-04-14 22:37

reporter   ~0130381

Seems to be caused by r64996

jamie philbrook

2021-04-14 22:57

reporter   ~0130382

Yup,. I just switched back to 64988 , that was yesterday for me..

I'll try again later...

jamie philbrook

2021-04-15 02:40

reporter   ~0130384

Looks like I can make it up to 64995 but that's it.

Martin Friebe

2021-04-15 18:26

manager   ~0130396

fixed

Issue History

Date Modified Username Field Change
2021-04-14 22:34 Bi0T1N New Issue
2021-04-14 22:37 Bi0T1N Note Added: 0130381
2021-04-14 22:57 jamie philbrook Note Added: 0130382
2021-04-15 02:40 jamie philbrook Note Added: 0130384
2021-04-15 08:55 Bart Broersma Assigned To => Martin Friebe
2021-04-15 08:55 Bart Broersma Status new => assigned
2021-04-15 18:26 Martin Friebe Status assigned => resolved
2021-04-15 18:26 Martin Friebe Resolution open => fixed
2021-04-15 18:26 Martin Friebe LazTarget => -
2021-04-15 18:26 Martin Friebe Widgetset Win32/Win64 => Win32/Win64
2021-04-15 18:26 Martin Friebe Note Added: 0130396
2021-04-15 22:06 Bi0T1N Status resolved => closed