View Issue Details

IDProjectCategoryView StatusLast Update
0038836PackagesPatchpublic2021-05-08 13:27
ReporterMartok Assigned Towp  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Summary0038836: VirtualTreeView: Infinite loop in GetPreviousVisibleNoInit()
DescriptionThere is an infinite loop in GetPreviousVisibleNoInit() when toChildrenAbove is used.

This is already fixed by upstream, please apply their patch.
https://github.com/JAM-Software/Virtual-TreeView/commit/a32eca7fb69f50779ace87975cc431ab380a9d5f
TagsNo tags attached.
Fixed in Revision65094
LazTarget-
Widgetset
Attached Files

Activities

Juha Manninen

2021-05-07 11:43

developer   ~0130786

Where is the master version of VirtualTreeView nowadays? Is it the JAM Software in Github?
Unfortunately there are many Lazarus port versions around, too. Luiz Americo maintains the master which is available through Online Package Manager.
Lazarus sources have a copy for the Online Package Manager itself. Apparently the infinite loop bug is not triggered by it.
I think the bug should be fixed in Luiz Americo's version. Please contact him.

wp

2021-05-07 14:37

developer   ~0130787

Our version contains the code before their patch. So I guess that we could have the same issue, independent of what Luiz will be doing. Please upload a demo project in which we can verify the issue.

Martok

2021-05-07 21:35

reporter   ~0130792

JAM Software is the current (since 2014) developer of the Delphi version, yes.

This report refers to components/virtualtreeview, which has received many updates since the initial copy that differ from Luiz' version. It certainly looks actively maintained and not just a copy of a particular version?
Of course I'm not against reporting this to other ports as well, I just don't use another one ;-)

Test project attached, expand the node to see it hang.
b0038836.zip (2,309 bytes)

wp

2021-05-07 22:26

developer   ~0130794

Thanks for demo. I can see the issue now and fixed it by applying the JAM software patch.
Please test again, and close if ok.

If you stumble across other issues fixed by JAM software feel free to report them. But always add a demo project.

Martok

2021-05-08 13:27

reporter   ~0130798

Works, thanks!

This is the first major bug in VT I found since about 2007, so I guess the next report is a while off :)

Issue History

Date Modified Username Field Change
2021-05-01 01:48 Martok New Issue
2021-05-07 11:43 Juha Manninen Note Added: 0130786
2021-05-07 14:37 wp Note Added: 0130787
2021-05-07 21:35 Martok Note Added: 0130792
2021-05-07 21:35 Martok File Added: b0038836.zip
2021-05-07 22:14 wp Assigned To => wp
2021-05-07 22:14 wp Status new => assigned
2021-05-07 22:26 wp Status assigned => resolved
2021-05-07 22:26 wp Resolution open => fixed
2021-05-07 22:26 wp Fixed in Revision => 65094
2021-05-07 22:26 wp LazTarget => -
2021-05-07 22:26 wp Note Added: 0130794
2021-05-08 13:27 Martok Status resolved => closed
2021-05-08 13:27 Martok Note Added: 0130798