View Issue Details

IDProjectCategoryView StatusLast Update
0038856LazarusLCLpublic2021-05-07 23:00
Reporterjamie philbrook Assigned ToMichl  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.12 
Fixed in Version2.1 (SVN) 
Summary0038856: AUTOSCROLL does not turn off scrollbars if UNCHECKED while scrollbars are showing.
DescriptionIf you use AUTOSCROLL bars on the form with controls on it of course and turn off the option while the scrollbars are still showing they remain on. expand the form and they are still showing..

 You need to turn on the AUTOSCROLL while the form is expanded for the scrollbars to turn off.
Steps To ReproduceWhile in the IDE using the designer...

Drop one control over to the right side, check the AUTOSCROLL feature and now shrink the form over that one control, you will now see the scrollbars.

Leaving the scrollbars displaying, UNCHECK the AUTOSCROLL feature and you will notice the scrollbars are still there.,

 Stretch the form to fully expose the control, the scrollbars are still there.

 You can only turn them off by turning on the AUTOSCROLL again with the form expanded.
TagsNo tags attached.
Fixed in Revision65089, 65093
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

jamie philbrook

2021-05-05 03:25

reporter   ~0130759

I forgot to mention that DELPHI behaves correctly in this respect.. the Scrollbars are turned off at any time you turn off the AUTOSCROLL.

Michl

2021-05-06 22:21

developer   ~0130776

38856_Test.zip (1,755 bytes)

jamie philbrook

2021-05-07 01:34

reporter   ~0130777

I just checked the trunk and it looks like it's working now.. The scrollbars will now turn off at any position..

If you are completed with this I guess it can be closed.

Michl

2021-05-07 22:04

developer   ~0130793

There was a issue on Windows 7 and DockedFormEditor. But thank you for the early feedback! If everything is OK, please close.

jamie philbrook

2021-05-07 23:00

reporter   ~0130795

Yes, looks good.. Closing..

Issue History

Date Modified Username Field Change
2021-05-05 03:19 jamie philbrook New Issue
2021-05-05 03:25 jamie philbrook Note Added: 0130759
2021-05-06 21:22 Michl Assigned To => Michl
2021-05-06 21:22 Michl Status new => assigned
2021-05-06 22:21 Michl Note Added: 0130776
2021-05-06 22:21 Michl File Added: 38856_Test.zip
2021-05-07 01:34 jamie philbrook Note Added: 0130777
2021-05-07 22:04 Michl Status assigned => resolved
2021-05-07 22:04 Michl Resolution open => fixed
2021-05-07 22:04 Michl Fixed in Version => 2.1 (SVN)
2021-05-07 22:04 Michl Fixed in Revision => 65089, 65093
2021-05-07 22:04 Michl LazTarget => -
2021-05-07 22:04 Michl Widgetset Win32/Win64 => Win32/Win64
2021-05-07 22:04 Michl Note Added: 0130793
2021-05-07 23:00 jamie philbrook Note Added: 0130795
2021-05-07 23:00 jamie philbrook Status resolved => closed