View Issue Details

IDProjectCategoryView StatusLast Update
0038863LazarusIDEpublic2021-05-07 07:32
ReporterMimarSinan Assigned ToMichael Van Canneyt  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.12 
Fixed in Version2.1 (SVN) 
Summary0038863: File Open Dialog on Cocoa Keeps Growing Wider and Wider with Each Invocation
DescriptionThe only requirement seems to be that the OS X version is Big Sur. The growth occurs for no discernible reason and will not stop. Please see attached screenshot for a wide dialog (that will be getting wider). No chance to resize the dialog to make it smaller either.
Steps To ReproduceJust use the open dialog on OS X Big Sur.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0038121 closedDmitry Boyarintsev OpenDialog with filters is getting bigger and bigger [cocoa] 

Activities

MimarSinan

2021-05-06 22:29

reporter  

Michael Van Canneyt

2021-05-07 05:38

administrator   ~0130778

I am seeing the same thing.
Additionally, the initial dialog is already several times wider than the screen,
forcing me to move the dialog before I can enter a filename.

Anton Kavalenka

2021-05-07 07:20

reporter   ~0130780

0038121

Michael Van Canneyt

2021-05-07 07:32

administrator   ~0130781

Seems to be fixed in trunk

Issue History

Date Modified Username Field Change
2021-05-06 22:29 MimarSinan New Issue
2021-05-06 22:29 MimarSinan File Added: Screen Shot 2021-05-06 at 3.26.41 PM.png
2021-05-07 05:38 Michael Van Canneyt Note Added: 0130778
2021-05-07 07:20 Anton Kavalenka Note Added: 0130780
2021-05-07 07:31 Michael Van Canneyt Relationship added duplicate of 0038121
2021-05-07 07:32 Michael Van Canneyt Assigned To => Michael Van Canneyt
2021-05-07 07:32 Michael Van Canneyt Status new => resolved
2021-05-07 07:32 Michael Van Canneyt Resolution open => duplicate
2021-05-07 07:32 Michael Van Canneyt Fixed in Version => 2.1 (SVN)
2021-05-07 07:32 Michael Van Canneyt LazTarget => -
2021-05-07 07:32 Michael Van Canneyt Note Added: 0130781