View Issue Details

IDProjectCategoryView StatusLast Update
0038876Lazarus CCROtherpublic2021-05-17 16:53
Reporterregs Assigned Towp  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0038876: fpExif will not save all sections info if some section is broken
DescriptionI have some files with seem to be broken IPTC sections. And in case if something wrong with IPTC section information from other sections won't load as well, like HasExif, image dimensions etc. It stops in TIptcReader.ReadIptcData with exception "IPTC data expected, but not found", as Length of ABuffer = 0. There is Exit afterwards, but it's not reachable because of exception.
TagsNo tags attached.
Widgetset
Attached Files

Activities

wp

2021-05-12 10:12

developer   ~0130826

Last edited: 2021-05-12 10:20

View 3 revisions

Please post a simple test project where I can see the issue and where I can see that you are not doing something wrong. And do not forget to add a picture with defective IPTC .

regs

2021-05-17 13:12

reporter   ~0130929

photos are little larger than 2MB, so a link. don't know the reason for unreadable iptc. the photo is not fully original. likely was edited and resaved by some app on the phone.
https://yadi.sk/d/FKciZ65aiGgwqg

wp

2021-05-17 16:53

developer   ~0130931

Please check r8034 in ccr, test and close if ok.

Your image has an IPTC segment, but it contains only zero bytes. I think this is a valid (although useless) file structure, and there is no need to raise an exception here. After this change, your image loads fine in my test programs.

Issue History

Date Modified Username Field Change
2021-05-12 03:02 regs New Issue
2021-05-12 10:12 wp Assigned To => wp
2021-05-12 10:12 wp Status new => assigned
2021-05-12 10:12 wp Note Added: 0130826
2021-05-12 10:12 wp Note Edited: 0130826 View Revisions
2021-05-12 10:20 wp Note Edited: 0130826 View Revisions
2021-05-17 11:28 wp Status assigned => feedback
2021-05-17 13:12 regs Note Added: 0130929
2021-05-17 13:12 regs Status feedback => assigned
2021-05-17 16:53 wp Note Added: 0130931
2021-05-17 16:53 wp Status assigned => resolved
2021-05-17 16:53 wp Resolution open => fixed