View Issue Details

IDProjectCategoryView StatusLast Update
0038901LazarusLCLpublic2021-05-18 16:53
ReporterRafael Picanco Assigned ToBart Broersma  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
Platformx86_64-linux-gtk2OSLinux 
Product Version2.1 (SVN) 
Summary0038901: clicking fast makes program unresponsive
DescriptionApplication becomes unresponsive after many clicks on a TButton.
Steps To Reproduce1) startlazarus
2) new project (form/application)
3) place a TButton on the form
4) click fast on the button
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Bart Broersma

2021-05-17 20:43

developer   ~0130933

Does the IDE (Lazarus) become unresponsive (you click the button in the IDE), or does this happen in the compiled program?

Rafael Picanco

2021-05-17 20:47

reporter   ~0130934

Hi Bart, it happen in the compiled program.

Rafael Picanco

2021-05-18 03:52

reporter   ~0130935

Sorry about that. It is not a bug at all.

Bart Broersma

2021-05-18 12:20

developer   ~0130938

As per original reporter.

Please close this bugreport.

Rafael Picanco

2021-05-18 16:53

reporter   ~0130940

The problem was caused by a circular reference inside the OnCreate event of the new form.

Issue History

Date Modified Username Field Change
2021-05-17 19:06 Rafael Picanco New Issue
2021-05-17 20:43 Bart Broersma Note Added: 0130933
2021-05-17 20:47 Rafael Picanco Note Added: 0130934
2021-05-18 03:52 Rafael Picanco Note Added: 0130935
2021-05-18 12:20 Bart Broersma Assigned To => Bart Broersma
2021-05-18 12:20 Bart Broersma Status new => resolved
2021-05-18 12:20 Bart Broersma Resolution open => no change required
2021-05-18 12:20 Bart Broersma LazTarget => -
2021-05-18 12:20 Bart Broersma Widgetset GTK 2 => GTK 2
2021-05-18 12:20 Bart Broersma Note Added: 0130938
2021-05-18 16:53 Rafael Picanco Status resolved => closed
2021-05-18 16:53 Rafael Picanco Note Added: 0130940