View Issue Details

IDProjectCategoryView StatusLast Update
0038982LazarusWidgetsetpublic2021-06-16 14:15
ReporterVojtech Cihak Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSLinux 
Product Version2.1 (SVN) 
Summary0038982: Error: Identifier not found "QString_toHtmlEscaped"
DescriptionCan't compile Lazarus+Qt4: qtwinapi.inc(5282,3) Error: Identifier not found "QString_toHtmlEscaped"

Lazarus 2.1.0 r65156M FPC 3.3.1 x86_64-linux-qt <-- This compiles fine yet. Later versions doesn't.
TagsNo tags attached.
Fixed in Revision65248
LazTarget-
WidgetsetQT
Attached Files

Relationships

related to 0038969 assignedZeljan Rikalo [LazOpenGLContext] GLQTContext unit not suitable for Windows 

Activities

Juha Manninen

2021-06-11 07:55

developer   ~0131250

It is caused by r65158: "Qt: fixed using of plain text in dialogs." by zeljko.

Zeljan Rikalo

2021-06-16 13:54

developer   ~0131331

Please test and close if ok.

Vojtech Cihak

2021-06-16 14:15

reporter   ~0131332

Tested with Lazarus 2.3.0 r65248M FPC 3.3.1 x86_64-linux-qt. Thanks.

Issue History

Date Modified Username Field Change
2021-06-10 15:48 Vojtech Cihak New Issue
2021-06-11 07:55 Juha Manninen Note Added: 0131250
2021-06-11 07:55 Juha Manninen Assigned To => Zeljan Rikalo
2021-06-11 07:55 Juha Manninen Status new => assigned
2021-06-11 08:32 Juha Manninen Relationship added related to 0038969
2021-06-16 13:54 Zeljan Rikalo Status assigned => resolved
2021-06-16 13:54 Zeljan Rikalo Resolution open => fixed
2021-06-16 13:54 Zeljan Rikalo Fixed in Revision => 65248
2021-06-16 13:54 Zeljan Rikalo LazTarget => -
2021-06-16 13:54 Zeljan Rikalo Widgetset QT => QT
2021-06-16 13:54 Zeljan Rikalo Note Added: 0131331
2021-06-16 14:15 Vojtech Cihak Status resolved => closed
2021-06-16 14:15 Vojtech Cihak Note Added: 0131332