View Issue Details

IDProjectCategoryView StatusLast Update
0038997FPCCompilerpublic2021-06-13 09:31
ReporterAlfred Assigned ToJonas Maebe  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionsuspended 
Summary0038997: Feature request for LLVM on Android Aarch64
DescriptionThe GNU binutils are permanently removed for Android NDK versions > 22, in favor of LLVM.
(the GNU assembler is still available )
Would it be possible to add Android Aarch64 as a target for the LLVM backend of FPC. If added, it would allow testing the LLVM backend for Android for (near) future NDK > 22.
Thanks.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Alfred

2021-06-13 08:41

reporter  

androidndk23.JPG (102,761 bytes)   
androidndk23.JPG (102,761 bytes)   

Jonas Maebe

2021-06-13 09:00

manager   ~0131277

FPC only uses the LLVM backend for code generation. Linking works in exactly the same way as when using the internal code generator. So this would not solve the issue you are pointing out.

Alfred

2021-06-13 09:27

reporter   ~0131278

In that case, this feature request can be closed.
Thanks for pointing out.

Jonas Maebe

2021-06-13 09:31

manager   ~0131279

It should be quite easy to add LLVM code generator support for the Android/AArch64 target in case anyone wants to though, since it's already supported for Linux/AArch64.

Issue History

Date Modified Username Field Change
2021-06-13 08:41 Alfred New Issue
2021-06-13 08:41 Alfred File Added: androidndk23.JPG
2021-06-13 09:00 Jonas Maebe Note Added: 0131277
2021-06-13 09:27 Alfred Note Added: 0131278
2021-06-13 09:31 Jonas Maebe Assigned To => Jonas Maebe
2021-06-13 09:31 Jonas Maebe Status new => resolved
2021-06-13 09:31 Jonas Maebe Resolution open => suspended
2021-06-13 09:31 Jonas Maebe FPCTarget => -
2021-06-13 09:31 Jonas Maebe Note Added: 0131279