View Issue Details

IDProjectCategoryView StatusLast Update
0039004LazarusDocumentationpublic2021-06-16 23:11
ReporterCudaText man Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformUbuntu 
Product Version2.1 (SVN) 
Summary0039004: IDE help tooltips for FileUtil functions should be better
DescriptionI checked only FIleUtil unit from LCL (pls see others) and here IDE shows floating tooltips not nice -
let's see - function ComparePhysicalFilenames

tooltip for it shows text like:
"Compares file names resolving sumbolic links
ComparePhysicalFilenames, like ......................."

What is bad - missed DOT char on the first line. So text looks like broken.
This issue is here for all FileUtil functions. Dot is missed for all funcs in the 1st sentence.

1) force dot-char in the IDE
or 2) add it in XML docs.
TagsNo tags attached.
Fixed in Revisionr65252
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0039011 closedMaxim Ganetsky [PATCH] codehelp adds '.' to short descriptions that already end with a punctuation character 

Activities

Don Siders

2021-06-15 18:11

reporter   ~0131319

It is an inconsistency in all of the help files, not just LazUtils. 18,000+ topics in LCL and LazUtils alone. 11.000+ topics in RTL and FCL. Not counting the .tex files used for other manuals.

While adding a period is a simple thing, the SVN change logs for this task would be HUGE.

I'm not arguing for or against... just pointing out the impact. I am not a fan of doctoring it in the Hint display though.

CudaText man

2021-06-15 18:40

reporter   ~0131320

It is caused by this XML tag

      <element name="ComparePhysicalFilenames">
        <short>Compares file names after resolving symbolic links</short>

so I will try to find where this "short" is reading to string.

CudaText man

2021-06-15 18:54

reporter   ~0131321

It was very easy. patch added.
h1.diff (782 bytes)   
Index: ide/codehelp.pas
===================================================================
--- ide/codehelp.pas	(revision 65243)
+++ ide/codehelp.pas	(working copy)
@@ -2939,7 +2939,14 @@
       if Node.NodeName='errors' then
         Result:=Result+'<div class="title">'+'Errors'+'</div>'
       else if Node.NodeName='seealso' then
-        Result:=Result+'<div class="title">'+'See also'+'</div>';
+        Result:=Result+'<div class="title">'+'See also'+'</div>'
+      else if Node.NodeName='short' then
+      begin
+        //fix Mantis issue #39004
+        s:=Trim(s);
+        if (s<>'') and (s[Length(s)]<>'.') then
+          s:=s+'.';
+      end;
       Result:=Result+'<div class="'+Node.NodeName+'">'+s+'</div>'+LineEnding;
     end else
     if (Node.NodeName='p')
h1.diff (782 bytes)   

Juha Manninen

2021-06-16 21:39

developer   ~0131345

Yes, it is actually a good change and doesn't add double dots. Applied, thanks.

Issue History

Date Modified Username Field Change
2021-06-14 19:18 CudaText man New Issue
2021-06-15 18:11 Don Siders Note Added: 0131319
2021-06-15 18:40 CudaText man Note Added: 0131320
2021-06-15 18:54 CudaText man Note Added: 0131321
2021-06-15 18:54 CudaText man File Added: h1.diff
2021-06-16 21:38 Juha Manninen Assigned To => Juha Manninen
2021-06-16 21:38 Juha Manninen Status new => assigned
2021-06-16 21:39 Juha Manninen Status assigned => resolved
2021-06-16 21:39 Juha Manninen Resolution open => fixed
2021-06-16 21:39 Juha Manninen Fixed in Revision => r65252
2021-06-16 21:39 Juha Manninen LazTarget => -
2021-06-16 21:39 Juha Manninen Widgetset GTK 2 => GTK 2
2021-06-16 21:39 Juha Manninen Note Added: 0131345
2021-06-16 22:46 CudaText man Status resolved => closed
2021-06-16 23:11 Juha Manninen Relationship added related to 0039011