View Issue Details

IDProjectCategoryView StatusLast Update
0000005Lazaruspublic2000-05-30 21:00
ReporterBug ImportAssigned ToMarc Weustink 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0000005: Canvas Fillrect doesn't use the brush color after it changes
Description<font face=verdana,arial,helvetica color=#cc6600>When you call fillrect, the color of the brush isn't used after you change it.


For example, in the TSpeedbutton.paint I change the Canvas.Brush.Fillrect to clBlue and then I do a Canvas.Fillrect(PaintRect) but it still uses the color clWhite (which is the color of the brush when it's created).


Can someone look at that? This is the reason the Speedbuttons always have a white border to the right and botton when they are flat.</font>
Additional InformationImported information
--------------------
Name: Shane Miller
Mail: smiller (at) lakefield.net
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2000-05-30 21:00

reporter   ~0000005

Marc:

I guess you mean Canvas.Brush.Color :)

I tested it with the following code:

  Canvas.Brush.Color := clBlue;
  Canvas.FillRect(Rect(50, 50, 100, 100));

and it indeed draws a white rectangle



It is related to bug 0000001

Issue History

Date Modified Username Field Change
2000-05-05 00:00 Bug Import New Issue
2000-05-05 00:00 Bug Import Widgetset => GTK, Win32
2000-05-30 21:00 Bug Import Status new => assigned
2000-05-30 21:00 Bug Import Assigned To => Marc Weustink
2000-05-30 21:00 Bug Import Note Added: 0000005
2000-05-30 21:00 Bug Import Status new => closed
2000-05-30 21:00 Bug Import Resolution open => fixed