View Issue Details

IDProjectCategoryView StatusLast Update
0007017LazarusIDEpublic2010-04-23 11:21
ReporterEduAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi686OSDebianOS Version 2-6-8-2-386
Product Version0.9.16Product Build 
Target VersionFixed in Version 
Summary0007017: Accents and Ñ (capital n with tilde) doesn't work in editor
DescriptionI can't add accented letters (á, é, í, Á, É, Í) or big ñ (Ñ) in the editor. I can, however, add those chars through copy-paste.

If I use LANG=es_ES.ISO-8859-15@euro, instead of á or Ñ it appears a and N, respectively.
If I use LANG=es_ES.ISO-8859-1, instead of á or Ñ it appears 'a (or an accented Z and a) and N
If I use LANG=es_ES.UTF-8, Lazarus tells me it doesn't work well with multibyte characters (and it doesn't!) and if I try to add á or whatever, the input is random.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK
Attached Files

Relationships

duplicate of 0001186 closedMarc Weustink "Key combos" do not work on the source code editor on gtk 
has duplicate 0007742 closedBart Broersma SynEdit cannot write accent chars even with font.CharSet = UNICODE 
has duplicate 0008855 acknowledged Editor does not support fully international keyboard layout 
has duplicate 0009755 closedVincent Snijders Entering single quote character from keyboard becomes A´ in Editor. 

Activities

Vincent Snijders

2006-06-03 15:09

manager   ~0008027

Last edited: 2006-06-03 15:09

Maybe too hard to fix with gtk1.

Edu

2006-06-03 16:16

reporter   ~0008029

OK, so a lot of copy-pasting is waiting me :D

Thanks for your response

Felipe Monteiro de Carvalho

2006-06-06 17:20

developer   ~0008100

This is a duplicate with some more interresting information about the bug.

Bart Broersma

2009-12-02 12:02

developer   ~0032659

I think this has been fixed in the meantime, with LCL now fully supporting UTF8?

Bart Broersma

2010-02-22 12:47

developer   ~0034668

No feedback from reporter.
Seems to be fixed in the meantime.
Please test and close if fixed, or re-open if issue remains.

Issue History

Date Modified Username Field Change
2006-06-03 12:08 Edu New Issue
2006-06-03 12:08 Edu Widgetset => GTK
2006-06-03 15:09 Vincent Snijders Target => post 1.0
2006-06-03 15:09 Vincent Snijders Note Added: 0008027
2006-06-03 15:09 Vincent Snijders Status new => acknowledged
2006-06-03 15:09 Vincent Snijders Note Edited: 0008027
2006-06-03 16:16 Edu Note Added: 0008029
2006-06-06 17:18 Felipe Monteiro de Carvalho Relationship added duplicate of 0001186
2006-06-06 17:20 Felipe Monteiro de Carvalho Note Added: 0008100
2006-11-04 00:32 Felipe Monteiro de Carvalho Relationship added has duplicate 0007742
2008-06-09 04:49 Felipe Monteiro de Carvalho Relationship added has duplicate 0008855
2009-12-02 12:02 Bart Broersma LazTarget post 1.0 => -
2009-12-02 12:02 Bart Broersma Note Added: 0032659
2009-12-02 12:02 Bart Broersma Status acknowledged => feedback
2009-12-02 12:07 Bart Broersma Relationship added has duplicate 0009755
2010-02-22 12:47 Bart Broersma Status feedback => resolved
2010-02-22 12:47 Bart Broersma Resolution open => fixed
2010-02-22 12:47 Bart Broersma Assigned To => Bart Broersma
2010-02-22 12:47 Bart Broersma Note Added: 0034668
2010-04-23 11:21 Bart Broersma Status resolved => closed