View Issue Details

IDProjectCategoryView StatusLast Update
0007181LazarusLCLpublic2012-12-26 15:50
ReporterPhilAssigned ToBart Broersma 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionduplicate 
PlatformIntel and PowerPCOSWin XP and OS XOS Version
Product Version0.9.17 (SVN)Product Build20060718 (Win) and 20060712 (OSX 
Target VersionFixed in Version 
Summary0007181: Problems using LCL in DLL
DescriptionI'm double-posting this because there appear to be several bugs and I'm not sure if they're in FPC or LCL.

I've uploaded a .zip file containing test programs that can be compiled with either Delphi or Lazarus.

GuiLib - VCL/LCL form in DLL
ConsoleTest - runs DLL form from console app
GuiTest - runs DLL form from GUI app

When GuiLib is compiled with Delphi, it works with both ConsoleTest and GuiTest compiled with either Delphi or Lazarus.

When GuiLib is compiled with Lazarus, works with ConsoleTest compiled with either Delphi or Lazarus on Windows. Does not work with GuiTest compiled with either Delphi or Lazarus on Windows (form is displayed but unresponsive). Does not work with either ConsoleTest or GuiTest on OS X using GTK widgetset (access violation).

An apparent FPC bug is evident when GuiLib is compiled with -Ct (stack check). This causes DLL function to exit immediately. This is also the case with most of my non-GUI DLL's as well, so I don't see it as a GUI issue.

Thanks.
TagsNo tags attached.
Fixed in Revision
LazTarget1.2
Widgetset
Attached Files

Relationships

duplicate of 0007182 resolvedOndrej Pokorny Problems using LCL in DLL 
has duplicate 0001866 resolvedOndrej Pokorny LCL not fully supported in library applications (.dlls) - Plug-in applications with GUI not working. 
related to 0018624 resolvedOndrej Pokorny TPopupMenu - Doesn't show on form from DLL 
related to 0022881 resolvedVincent Snijders Combobox loses inheritance information 

Activities

2006-07-19 21:54

 

LCLinDLL.zip (12,190 bytes)

Issue History

Date Modified Username Field Change
2006-07-19 21:54 Phil New Issue
2006-07-19 21:54 Phil File Added: LCLinDLL.zip
2006-07-19 21:54 Phil Widgetset => Win32
2006-08-17 22:06 Vincent Snijders Target => post 1.0
2006-08-17 22:06 Vincent Snijders Status new => acknowledged
2007-11-27 14:31 Felipe Monteiro de Carvalho Relationship added has duplicate 0007182
2007-11-27 15:08 Felipe Monteiro de Carvalho Relationship added has duplicate 0001866
2011-11-20 12:33 Juha Manninen Relationship added related to 0018624
2012-02-04 12:05 Zeljan Rikalo LazTarget post 1.0 => 1.2
2012-09-14 19:58 Juha Manninen Relationship added related to 0022881
2012-12-26 15:49 Bart Broersma Widgetset Win32/Win64 =>
2012-12-26 15:49 Bart Broersma Relationship replaced duplicate of 0007182
2012-12-26 15:49 Bart Broersma Duplicate ID 0 => 7182
2012-12-26 15:49 Bart Broersma Status acknowledged => resolved
2012-12-26 15:49 Bart Broersma Resolution open => duplicate
2012-12-26 15:49 Bart Broersma Assigned To => Bart Broersma