View Issue Details

IDProjectCategoryView StatusLast Update
0000072Lazaruspublic2004-03-17 08:34
ReporterBug ImportAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0000072: MouseUp event fires even if user dragged mouse off control
DescriptionI've discovered that, unlike windows, an onmouseup event will fire even if a user has clicked down and then dragged off the control.

For instance... I'm tracking changes in radio buttons with this event, however if the user clicks down, then drags off the radio button, my onmouseup event launches, but the radio button does not change. I have no way of knowing if the radio button was _ABOUT_ to change or not, because this event launches before the change is actually made.
Additional InformationImported information
--------------------
Name: Tony Maro
Mail: tonym (at) nlisc.com
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2004-03-17 08:34

reporter   ~0000055

Use OnClick

Dragging the mouse grabs the mouse and so the OnMouseUp goes to the dragging control.

MG

Issue History

Date Modified Username Field Change
2002-09-29 00:00 Bug Import New Issue
2002-09-29 00:00 Bug Import Widgetset => GTK, Win32
2004-03-17 08:34 Bug Import Status new => assigned
2004-03-17 08:34 Bug Import Assigned To => Mattias Gaertner
2004-03-17 08:34 Bug Import Note Added: 0000055
2004-03-17 08:34 Bug Import Status new => closed
2004-03-17 08:34 Bug Import Resolution open => no change required