View Issue Details

IDProjectCategoryView StatusLast Update
0000075Lazaruspublic2002-10-14 11:25
ReporterBug ImportAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0000075: Changing name of new form corrupts things
DescriptionSometimes - about 40% of the time - when I create a new form, then go to the property editor and change the name to something else, it results in something like this:

Chose FILE + NEW FORM

Went to property editor and changed name to "FrmEnterWithdrawal".

The property editor shows things correctly, but here's what the form's unit shows:

type
  TFrmEnterWithdrawalTFrmEnterWithdrawal = class(TForm)
  private
    { private declarations }
  public
    { public declarations }
  end;

var
  FrmEnterWithdrawalFrmEnterWithdrawal: TFrmEnterWithdrawalTFrmEnterWithdrawal;

(No I didn't stutter)
Sometimes it will do this 8 times in a row. Other times I can't reproduce it.
Additional InformationImported information
--------------------
Name: Tony Maro
Mail: tonym (at) nlisc.com
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2002-10-14 11:25

reporter   ~0000058

MG

Issue History

Date Modified Username Field Change
2002-10-04 00:00 Bug Import New Issue
2002-10-04 00:00 Bug Import Widgetset => GTK, Win32
2002-10-14 11:25 Bug Import Status new => assigned
2002-10-14 11:25 Bug Import Assigned To => Mattias Gaertner
2002-10-14 11:25 Bug Import Note Added: 0000058
2002-10-14 11:25 Bug Import Status new => closed
2002-10-14 11:25 Bug Import Resolution open => fixed