View Issue Details

IDProjectCategoryView StatusLast Update
0007635LazarusLCLpublic2012-02-05 17:01
ReporterDavid MearsAssigned ToLuiz Americo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.19 (SVN) 
Target Version1.0.0 
Summary0007635: tdbcombobox in combination with tmemdataset and .clear then append, under linux
DescriptionProject raised exception class 'MD5Error' with message Bookmark 0 not found

error occurs if you clear the data from the dataset and then try to append a new record to it, when there are items in the items field.

if there are no items in the combobox, it doesn't raise the error.
clearing the dataset itself doesn't raise the error.
if there are no tdbcombobox(s) then the error isn't raised.
error occurs when "append" happens.
if it's under windows it doesn't raise the error at all.

Occurs with gtk and gtk2 widgetset under Linux. Occurs with latest SVN and 9.18 release version. Haven't tried other widgetsets since they are problematic to compile.
Additional Informationminimal example attached. Click button twice to raise error.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK, GTK 2
Attached Files

Activities

2006-10-20 00:52

 

testcase2.zip (4,015 bytes)

David Mears

2006-10-20 14:13

reporter   ~0009459

issue continues with latest FPC & laz, however, does appear to go away when the dubugger is turned off. That means if the underlying code isn't doing anything too evil, it's just an annoyance for now.

Zeljan Rikalo

2012-02-04 11:35

developer   ~0056359

@Luiz please look what to do with this one. Postpone if needed.

Luiz Americo

2012-02-05 17:00

developer   ~0056538

Fixed in mean time

Issue History

Date Modified Username Field Change
2006-10-20 00:52 David Mears New Issue
2006-10-20 00:52 David Mears File Added: testcase2.zip
2006-10-20 00:52 David Mears Widgetset => GTK, GTK 2
2006-10-20 14:13 David Mears Note Added: 0009459
2006-12-02 18:27 Vincent Snijders LazTarget => 1.0
2006-12-02 18:27 Vincent Snijders Status new => acknowledged
2008-04-24 07:57 Vincent Snijders Target Version => 1.0.0
2012-02-04 11:35 Zeljan Rikalo Note Added: 0056359
2012-02-04 11:35 Zeljan Rikalo Assigned To => Luiz Americo
2012-02-04 11:35 Zeljan Rikalo Status acknowledged => assigned
2012-02-05 17:00 Luiz Americo Status assigned => resolved
2012-02-05 17:00 Luiz Americo Resolution open => fixed
2012-02-05 17:00 Luiz Americo Note Added: 0056538