View Issue Details

IDProjectCategoryView StatusLast Update
0000077Lazaruspublic2002-10-14 15:43
ReporterBug ImportAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0000077: OI created events sometimes end up on wrong form
DescriptionThis may be related to the "unpublished" event issue I listed earlier, because I just noticed that's when it happens as well...

When using the OI to create (or sometimes just click the button to edit) a new event for an object, sometimes it will create the event both in the proper unit AND in another unit.

I've seen this happen several times, but like some other things I can't guess as to when or why it will happen.

For instance: I just noticed my FrmEnterWithdrawal and my FrmEnterDep did the following:

{ in FrmEnterWIthdrawal's unit: }
procedure TFrmEnterWithdrawal.FrmEnterWithdrawalCREATE(Sender: TObject);

{ in FrmEnterDep's unit: }
procedure TFrmEnterDep.FrmEnterWithdrawalCREATE(Sender: TObject);

It even creates the reference in the forms type definition to match the mismatched routine.

I noticed it this time because after it happened, the TFrmEnterWithdrawal.OnCreate event existed, but the OI showed "UNPUBLISHED" instead of the routine name.

I hope this helps...
Additional InformationImported information
--------------------
Name: Tony Maro
Mail: tony (at) maro.net
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2002-10-14 15:43

reporter   ~0000060

MG

Issue History

Date Modified Username Field Change
2002-10-04 00:00 Bug Import New Issue
2002-10-04 00:00 Bug Import Widgetset => GTK, Win32
2002-10-14 15:43 Bug Import Status new => assigned
2002-10-14 15:43 Bug Import Assigned To => Mattias Gaertner
2002-10-14 15:43 Bug Import Note Added: 0000060
2002-10-14 15:43 Bug Import Status new => closed
2002-10-14 15:43 Bug Import Resolution open => fixed