View Issue Details

IDProjectCategoryView StatusLast Update
0007742LazarusOtherpublic2010-04-23 11:20
ReporterAles KatonaAssigned ToBart Broersma 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86_32OSFreeBSDOS Version6.1
Product VersionProduct Build 
Target Version1.0.0Fixed in Version 
Summary0007742: SynEdit cannot write accent chars even with font.CharSet = UNICODE
DescriptionIf I use SenEdit in either gtk1 or gtk2 and set it's font.charset to UNICODE (had to find out it's 4 btw, where is the constant defined?) I can read UTF-8 files ok, I can also write all chars which don't require a "accent" key.

Let me explain:

If you wish to write eg: á (should look like a with small ' above)
You can either write it using one prepared key in slovak keyboard (where 8 is on the non-numpad) OR write the "´" (should be that small thing) and THEN press normal "a".

It's not a big problem where the choice exists, but not all accented chars are available on the keyboard. I'm sure other languages have such thing too.

In gtk1 I get the "a" and "´" as 2 separate chars if I try to write with 2 keys.
In gtk2 I get only normal "a".
Steps To ReproduceSet SynEdit.Fond.Charset to 4 (UNICODE) and try to write accented chars via the accent modifier keys.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK
Attached Files

Relationships

duplicate of 0001186 closedMarc Weustink "Key combos" do not work on the source code editor on gtk 
duplicate of 0007017 closedBart Broersma Accents and Ñ (capital n with tilde) doesn't work in editor 
duplicate of 0008855 acknowledged Editor does not support fully international keyboard layout 
has duplicate 0009755 closedVincent Snijders Entering single quote character from keyboard becomes A´ in Editor. 

Activities

Ales Katona

2006-11-03 16:38

developer   ~0009652

Vincent corrected me on the gtk1 problem with dead keys.

But with gtk2 this is still a bug.

Felipe Monteiro de Carvalho

2006-11-04 00:34

developer   ~0009660

Thanks for adding additional information for this bug.

After Windows Unicode, this bug is the biggest problem for full Unicode support on Lazarus.

Ales Katona

2007-08-10 11:41

developer   ~0014075

Works in gtk2 now

Vincent Snijders

2007-08-10 12:21

manager   ~0014082

Now it is a gtk 1 only bug.

theo

2008-03-27 15:00

reporter   ~0018462

It does not work for me in GTK2, SVN Rev 14640.
I have a Swiss German Keyboard $LANG=de_CH.UTF-8

For ex. I'd like to write a "â" like in Château.
Two problems:
1: When testing with Keyboard events on a Form or Synedit, UTF8KeyPress is never called (see below)
2: When typing in a TEdit or TMemo etc. the correct character appears but twice (ââ)

Testing all Keyb. events on a form with writeln returns this:

--- Hit the "^" Key
KeyDown 146
KeyUp 146
--- Hit the "a" Key after this-> No UTF8Keypress event. Keypress has normal "a"
KeyDown 65
KeyPress a
KeyUp 65
--- Hit the "a" Key again -> TF8Keypress event with normal "a"
KeyDown 65
UTF8KeyPress a
KeyPress a
KeyUp 65


The "â" is not so important for the source editor, but it's the same problem for "^". I can't type this char in GTK2 IDE but I can paste it from CB.

theo

2008-03-28 12:16

reporter   ~0018469

@Felipe: I don't think 0011045 is closely related. It's, as you say, rather trivial that different source file encodings cause some trouble.

I will sum up the observations for my system:

GTK1: TSynedit -> '^' appears immediately (does not act as a dead key)
GTK1: TMemo -> '^' appears (acts like a dead key) everything fine!
GTK2: TSynedit -> '^' nothing appears, but blocks the UTF8Keypress event of the next keystroke. (see above)
GTK2: TMemo -> '^' appears, acts like a dead key but inserts the char twice.

Other GTK2 based Apps work as expected on my System

Bart Broersma

2009-12-02 12:03

developer   ~0032660

I think this has been fixed in the meantime, with LCL now fully supporting UTF8?

Bart Broersma

2010-02-22 12:48

developer   ~0034669

No feedback from reporter.
Seems to be fixed in the meantime.
Please test and close if fixed, or re-open if issue remains.

Issue History

Date Modified Username Field Change
2006-11-03 16:24 Ales Katona New Issue
2006-11-03 16:24 Ales Katona LazTarget => -
2006-11-03 16:24 Ales Katona Widgetset => GTK
2006-11-03 16:38 Ales Katona Note Added: 0009652
2006-11-03 16:39 Ales Katona Widgetset GTK => GTK 2
2006-11-04 00:31 Felipe Monteiro de Carvalho Relationship added duplicate of 0001186
2006-11-04 00:32 Felipe Monteiro de Carvalho Relationship added duplicate of 0007017
2006-11-04 00:34 Felipe Monteiro de Carvalho Note Added: 0009660
2006-11-04 00:34 Felipe Monteiro de Carvalho Status new => acknowledged
2006-12-04 14:01 Vincent Snijders LazTarget - => 1.0
2007-08-10 11:41 Ales Katona Note Added: 0014075
2007-08-10 12:21 Vincent Snijders Widgetset GTK 2 => GTK
2007-08-10 12:21 Vincent Snijders Note Added: 0014082
2008-03-27 15:00 theo Note Added: 0018462
2008-03-28 11:38 Felipe Monteiro de Carvalho Relationship added related to 0011045
2008-03-28 12:16 theo Note Added: 0018469
2008-03-28 23:16 Felipe Monteiro de Carvalho Relationship deleted related to 0011045
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2009-12-02 12:00 Bart Broersma Relationship added duplicate of 0008855
2009-12-02 12:03 Bart Broersma Note Added: 0032660
2009-12-02 12:03 Bart Broersma Status acknowledged => feedback
2009-12-02 12:07 Bart Broersma Relationship added has duplicate 0009755
2010-02-22 12:48 Bart Broersma Status feedback => resolved
2010-02-22 12:48 Bart Broersma Resolution open => fixed
2010-02-22 12:48 Bart Broersma Assigned To => Bart Broersma
2010-02-22 12:48 Bart Broersma Note Added: 0034669
2010-04-23 11:20 Bart Broersma Status resolved => closed