View Issue Details

IDProjectCategoryView StatusLast Update
0007879LazarusIDEpublic2012-04-02 16:36
ReporterSamAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.21 (SVN)Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0007879: Right-clicking on Tabs doesn't show list of units
DescriptionWhen right-clicking on the tabs in the Source editor the menu that appears is the same as if you right-click in the actual editor. On Linux, if you right-click the tabs you get a menu which contain a list of the open units which aids navigation.
Additional InformationOperating system is winXP with SP2
Lazarus isv9.21 build 10233M
TagsNo tags attached.
Fixed in Revision
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Activities

2006-11-24 14:41

 

menu screenshot.PNG (112,905 bytes)
menu screenshot.PNG (112,905 bytes)

Vincent Snijders

2006-11-24 20:29

manager   ~0009966

The tab widget in gtk is more powerful than in windows, so it seems.

Zeljan Rikalo

2010-03-10 09:48

developer   ~0035133

This is because gtk2 tabs have context menu mapped to tab buttons.
Under qt & win32 when you right click onto tab you get editor menu.
So, what to do here:
Implement units list for qt,carbon & win32 or override gtk's default context menu (btw I have to click few times onto tab button to see units list under gtk2).

Vincent Snijders

2010-12-05 20:21

manager   ~0044016

Zeljan, what feedback do you want to have on this issue?

Zeljan Rikalo

2010-12-06 08:09

developer   ~0044032

I want to know:
1.Do we need to implement context menu with units on tabs (like gtk have).
2.Close this issue and document this gtk behaviour.

Vincent Snijders

2011-03-31 08:34

manager   ~0046992

Sam, what do you think that we should do?

Martin Friebe

2012-04-02 16:36

manager   ~0058257

Menus where updated. Tab list is now present on all platforms

Issue History

Date Modified Username Field Change
2006-11-24 14:41 Sam New Issue
2006-11-24 14:41 Sam File Added: menu screenshot.PNG
2006-11-24 14:41 Sam Widgetset => Win32
2006-11-24 20:29 Vincent Snijders LazTarget => post 1.0
2006-11-24 20:29 Vincent Snijders Note Added: 0009966
2006-11-24 20:29 Vincent Snijders Status new => acknowledged
2010-03-10 09:48 Zeljan Rikalo LazTarget post 1.0 => -
2010-03-10 09:48 Zeljan Rikalo Note Added: 0035133
2010-03-10 09:48 Zeljan Rikalo Status acknowledged => feedback
2010-11-06 14:34 Zeljan Rikalo LazTarget - => 1.2
2010-12-05 20:21 Vincent Snijders Note Added: 0044016
2010-12-06 08:09 Zeljan Rikalo Note Added: 0044032
2011-03-31 08:34 Vincent Snijders Note Added: 0046992
2012-04-02 16:36 Martin Friebe Status feedback => resolved
2012-04-02 16:36 Martin Friebe Fixed in Version => 0.9.31 (SVN)
2012-04-02 16:36 Martin Friebe Resolution open => fixed
2012-04-02 16:36 Martin Friebe Assigned To => Martin Friebe
2012-04-02 16:36 Martin Friebe Note Added: 0058257