View Issue Details

IDProjectCategoryView StatusLast Update
0007937Lazarus-public2011-12-01 11:24
Reporterda_Seeb Assigned ToFelipe Monteiro de Carvalho  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Target Version1.0.0 
Summary0007937: Listview column autosize win32
Descriptionautosize of the columns in a listview doesn't work under win32
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0007938 resolvedZeljan Rikalo Listview column autosize gtk2 
related to 0012533 closedFelipe Monteiro de Carvalho Listview autosize does not work. 
has duplicate 0016690 closedFelipe Monteiro de Carvalho TListView.columns[].Autosize problem 
has duplicate 0016946 closedFelipe Monteiro de Carvalho TListView column autosize problem in ToDo list 
related to 0017115 assignedDmitry Boyarintsev TListView Column.Autosize doesn't work in Carbon 

Activities

equinox

2007-09-28 20:01

reporter   ~0014966

Last edited: 2007-09-28 20:02

I checked in a newer version 15.9.2007, It is not ok yet

equinox

2007-09-28 22:43

reporter   ~0014969

Last edited: 2007-09-28 22:47

I examined this issue..
There are two problems...

1. The problem is a certain windows message should be sent each time the listview is updated. This does not happen only at the beginning.
2. at the beginning , when a list view is initialised, the autosized columns width are set but then they are overridden with normal widths.
The question is where this call (which sets the columns width) should be placed.

Basically, this should be called for each column
SendMessage(ListView1.Handle,LVM_SETCOLUMNWIDTH,WPARAM(columnno),MAKELPARAM(LVSCW_AUTOSIZE,0));
(unit Windows)
Until it is solved, this message can be called each time the list view changes.

Vincent Snijders

2008-06-12 11:26

manager   ~0020104

Can you upload an example application with steps to reproduce the issue?

Vincent Snijders

2008-07-08 23:13

manager   ~0020608

No feedback from reporter.

da_Seeb

2009-05-27 13:29

reporter   ~0028045

still not fixed in current revisions

Vincent Snijders

2009-05-27 15:57

manager   ~0028055

Can you upload an example application with steps to reproduce the issue?

da_Seeb

2009-05-29 10:06

reporter   ~0028130

try the example project I have attached for the same GTK2 issue

http://bugs.freepascal.org/view.php?id=7938

Felipe Monteiro de Carvalho

2010-07-27 13:57

developer   ~0039729

Fixed in the patch from the bug report 12533

Issue History

Date Modified Username Field Change
2006-12-08 15:18 da_Seeb New Issue
2006-12-08 15:18 da_Seeb Widgetset => Win32
2006-12-08 15:49 Vincent Snijders LazTarget => 1.0
2006-12-08 15:49 Vincent Snijders Status new => acknowledged
2007-09-28 20:01 equinox Note Added: 0014966
2007-09-28 20:02 equinox Note Edited: 0014966
2007-09-28 20:02 equinox Note Edited: 0014966
2007-09-28 22:43 equinox Note Added: 0014969
2007-09-28 22:46 equinox Note Edited: 0014969
2007-09-28 22:47 equinox Note Edited: 0014969
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2008-06-12 11:26 Vincent Snijders Note Added: 0020104
2008-06-12 11:26 Vincent Snijders Status acknowledged => feedback
2008-07-08 23:13 Vincent Snijders Status feedback => resolved
2008-07-08 23:13 Vincent Snijders Resolution open => unable to reproduce
2008-07-08 23:13 Vincent Snijders Assigned To => Vincent Snijders
2008-07-08 23:13 Vincent Snijders Note Added: 0020608
2009-05-27 13:29 da_Seeb Status resolved => assigned
2009-05-27 13:29 da_Seeb Resolution unable to reproduce => reopened
2009-05-27 13:29 da_Seeb Note Added: 0028045
2009-05-27 15:57 Vincent Snijders Note Added: 0028055
2009-05-27 15:57 Vincent Snijders Status assigned => feedback
2009-05-27 15:58 Vincent Snijders Assigned To Vincent Snijders =>
2009-05-29 10:06 da_Seeb Note Added: 0028130
2009-06-17 23:20 Vincent Snijders Status feedback => acknowledged
2010-04-27 04:27 Paul Ishenin Relationship added related to 0007938
2010-04-27 04:27 Paul Ishenin Relationship added related to 0012533
2010-07-27 09:46 Felipe Monteiro de Carvalho Status acknowledged => assigned
2010-07-27 09:46 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2010-07-27 13:57 Felipe Monteiro de Carvalho Status assigned => resolved
2010-07-27 13:57 Felipe Monteiro de Carvalho Resolution reopened => fixed
2010-07-27 13:57 Felipe Monteiro de Carvalho Note Added: 0039729
2010-08-05 15:42 Felipe Monteiro de Carvalho Relationship added has duplicate 0016690
2010-08-05 15:44 Felipe Monteiro de Carvalho Relationship added has duplicate 0016946
2010-08-05 15:45 Felipe Monteiro de Carvalho Relationship added related to 0017115
2011-12-01 11:24 Marc Weustink Status resolved => closed