View Issue Details

IDProjectCategoryView StatusLast Update
0007971LazarusIDEpublic2015-12-14 13:03
ReporterMichael EAssigned ToOndrej Pokorny 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.20Product Build 
Target VersionFixed in Version1.6 
Summary0007971: Bad Xinerama support
DescriptionWhen I tried open any IDE's dialog window it opens in the middle of two monitrors instead in center of monitor where is IDE is running.
Tagsmulti-monitor
Fixed in Revision
LazTarget-
WidgetsetGTK
Attached Files

Relationships

related to 0010330 closedPaul Ishenin misplaced code-completion hint on windows, with desktop across multi-monitor 
related to 0012640 resolvedJuha Manninen Use Sreen/Monitor instead of Desktop for windows and dialogs. 

Activities

Juha Manninen

2011-11-20 12:08

developer   ~0054296

Has this improved?

Ondrej Pokorny

2015-11-26 19:19

reporter   ~0087620

Has this improved?

Mark Morgan Lloyd

2015-11-26 20:17

reporter   ~0087621

Last edited: 2015-11-27 09:52

View 2 revisions

I use Xinerama with GTK2 and notice no significant problems.

I had Xinerama with GTK (i.e. specifically on a distro that used GTK1 by default) until comparatively recently, I think that any dialog(ue) positioning etc. is more a GTK thing rather than a problem with Lazarus.

Ondrej Pokorny

2015-11-26 20:54

reporter   ~0087626

Last edited: 2015-11-26 21:13

View 2 revisions

Thanks for the info. I'll keep this issue open for some time and if no one confirms the problem, I'll close it. I worked on multiple monitor support recently and it seems to be OK.

This issue looks like the dialogs used "poDesktopCenter" as TForm.Position but Lazarus IDE doesn't use it anywhere anymore. (I found it in just some examples.)

Mark Morgan Lloyd

2015-11-27 09:51

reporter   ~0087636

I've got a very small number of programs that I try to keep good for GTK1, just in case somebody from e.g. a mainframe community tries to use them... the last thing I want to do is convince an outsider that FPC/Lazarus is picky about OS versions etc.

Having said that, I think the real issue is not so much whether a fix is viable, as whether it could either be retrospectively applied to e.g. fixes_0_9_24 or whether the current IDE/LCL could be built in a form still compatible with GTK1.

My own feeling is that either of these would require a firm commitment from somebody who was prepared to test and possibly maintain the result, and that they are very much overshadowed by ongoing problems relating to GTK2 particularly on e.g. recent Debian versions.

Ondrej Pokorny

2015-12-13 16:18

reporter   ~0087931

I don't have enough knowledge to make a correct decision. I am detaching myself.

Maxim Ganetsky

2015-12-14 13:03

developer   ~0087950

@Mark: We do not actively support GTK1 widgetset for a long time. I even doubt that it will build in latest Lazarus versions.

Also we don't support any Lazarus version older than 1.4 series.

So you are free to investigate these issues yourself.

I see no point in keeping this bug open anymore. Resolving and assigning to Ondrej.

Issue History

Date Modified Username Field Change
2006-12-15 09:21 Michael E New Issue
2006-12-15 09:21 Michael E Widgetset => GTK
2006-12-15 09:27 Vincent Snijders LazTarget => post 1.0
2006-12-15 09:27 Vincent Snijders Status new => acknowledged
2009-04-07 11:34 Paul Ishenin Relationship added related to 0010330
2009-04-07 11:37 Paul Ishenin Tag Attached: multi-monitor
2011-11-20 12:08 Juha Manninen Relationship added related to 0012640
2011-11-20 12:08 Juha Manninen Note Added: 0054296
2012-02-04 12:10 Zeljan Rikalo LazTarget post 1.0 => 1.2
2014-01-14 15:16 Martin Friebe LazTarget 1.2 => 1.4
2014-09-10 01:00 Juha Manninen LazTarget 1.4 => -
2015-11-26 19:19 Ondrej Pokorny Note Added: 0087620
2015-11-26 20:17 Mark Morgan Lloyd Note Added: 0087621
2015-11-26 20:54 Ondrej Pokorny Note Added: 0087626
2015-11-26 21:13 Ondrej Pokorny Note Edited: 0087626 View Revisions
2015-11-27 09:51 Mark Morgan Lloyd Note Added: 0087636
2015-11-27 09:52 Mark Morgan Lloyd Note Edited: 0087621 View Revisions
2015-12-13 16:18 Ondrej Pokorny Note Added: 0087931
2015-12-14 13:03 Maxim Ganetsky Note Added: 0087950
2015-12-14 13:03 Maxim Ganetsky Status acknowledged => resolved
2015-12-14 13:03 Maxim Ganetsky Fixed in Version => 1.6
2015-12-14 13:03 Maxim Ganetsky Resolution open => fixed
2015-12-14 13:03 Maxim Ganetsky Assigned To => Ondrej Pokorny