View Issue Details

IDProjectCategoryView StatusLast Update
0008165LazarusIDEpublic2011-12-01 11:22
Reporteruser268Assigned ToMattias Gaertner  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformLinux 
Product Version0.9.21 (SVN) 
Target Version0.9.28Fixed in Version0.9.27 (SVN) 
Summary0008165: GTK2 - suggested to be default
DescriptionThe latest Linux distros comes with GTK2 support only.
Perhaps it is time to set GTK2 by default during building Lazarus, without forcing compiler with LCL_PLATFORM=gtk2.
TagsNo tags attached.
Fixed in Revision
LazTarget0.9.28
WidgetsetGTK 2
Attached Files

Relationships

parent of 0011168 closedFelipe Monteiro de Carvalho Lazarus/the developed application crashes if a TTrayIcon is enabled 
parent of 0011591 closedMarc Weustink Keys not consistently reported in TMemo OnKey... events 
parent of 0011485 closedAles Katona Color property has no effect in TPanel (Linux - GTK2) 
parent of 0011122 resolvedVincent Snijders Painting bug in GTK2: TLabel 
parent of 0011120 closedPaul Ishenin Painting bug in GTK2: TButton 
parent of 0011121 resolvedJuha Manninen Painting bug in GTK2: TRadioButton 
parent of 0000964 acknowledged GTK2 seems to paint in reverse order...? 
parent of 0000974 closedAles Katona GTK2 resizing of TFileListBox in IDE moves the component 
parent of 0001928 closedVincent Snijders Some components can't put correctly within TGroupbox and TDBGroupbox using GTK2 
parent of 0007717 closedMartin Friebe Scrolling down with arrow in TSynEdit = 100%CPU 
parent of 0007828 closedMartin Friebe Editor text painting effect when highlighting text 
parent of 0008853 closedVincent Snijders Closing unit on tab's X closes all other units 
parent of 0009273 closedAles Katona settings property checked for radiobutton call also OnClickEvent 
parent of 0009293 closedAles Katona Cannot change color of a form. 
parent of 0009303 closedPaul Ishenin Forms color properties becomes corrupted ater using color selector dialog.. 
parent of 0010668 closedAles Katona DropDownCount of ComboBox with GTK2 does not work 
parent of 0009568 closedJesus Reyes Grid's picklist is broken 
parent of 0010680 closedJuha Manninen ComboBox onClic event with gtk2 is not correctly raised, and so is the onEnter event 
parent of 0011007 closedAles Katona PopupMenu does not pop up in TMemo (Linux) 
parent of 0011935 closedPaul Ishenin Font.Size size changes after second Showmodal for many widgets 
parent of 0012247 closedZeljan Rikalo Showmodal not modal 
parent of 0012315 closedPaul Ishenin Tlabel.autosize has only one value in object inspector 
parent of 0012314 closedPaul Ishenin TLabel font.color and color not working 
parent of 0012324 closedPaul Ishenin "View project units" doesn't allows multiselect 
parent of 0012396 closedPaul Ishenin Lazarus crashes when trying to copy text in the editor. 
parent of 0012952 closedPaul Ishenin Source editor is missing file tabs after program execution is stopped 
parent of 0012460 closedMartin Friebe Editor stop selecting text [Caused by hint window / temp work around applied] 
has duplicate 0012089 closedVincent Snijders GTK2 should be the standart widgetset for Linux 
Not all the children of this issue are yet resolved or closed.

Activities

Vincent Snijders

2007-01-21 19:55

manager   ~0011002

When gtk2 is more stable then lazarus+gtk1.

Ales Katona

2008-07-16 19:27

developer   ~0020748

Won't happen unless you make it default and users test it properly and devs have more motivation to fix it.

Vincent Snijders

2008-07-16 20:11

manager   ~0020750

Last edited: 2008-07-16 20:13

Let's first fix the pending bugs. No need for more testers, yet. Or do you want to annoy Lazarus users into bug fixing? Lazarus developers that need a stable ide will circumvent it if gtk2 is the default and Lazarus developers that want to test gtk2 know how to compile for gtk2.

Vincent Snijders

2009-09-27 11:20

manager   ~0031000

The remaining open child issues have been given target 1.0.

Issue History

Date Modified Username Field Change
2007-01-21 19:14 user268 New Issue
2007-01-21 19:14 user268 Widgetset => GTK 2
2007-01-21 19:55 Vincent Snijders LazTarget => post 1.0
2007-01-21 19:55 Vincent Snijders Note Added: 0011002
2007-01-21 19:55 Vincent Snijders Status new => acknowledged
2007-05-09 10:44 Felipe Monteiro de Carvalho LazTarget post 1.0 => 1.2
2008-07-16 19:25 Vincent Snijders Relationship added has duplicate 0011669
2008-07-16 19:27 Ales Katona Note Added: 0020748
2008-07-16 20:11 Vincent Snijders Note Added: 0020750
2008-07-16 20:13 Vincent Snijders Note Edited: 0020750
2008-07-16 20:14 Mattias Gaertner Status acknowledged => assigned
2008-07-16 20:14 Mattias Gaertner Assigned To => Mattias Gaertner
2008-07-16 20:25 Vincent Snijders Relationship added parent of 0011168
2008-07-16 20:31 Vincent Snijders Relationship added parent of 0011591
2008-07-16 20:32 Vincent Snijders Relationship added parent of 0011485
2008-07-16 20:32 Vincent Snijders Relationship added parent of 0011122
2008-07-16 20:33 Vincent Snijders Relationship added parent of 0011120
2008-07-16 20:33 Vincent Snijders Relationship added parent of 0001121
2008-07-16 20:33 Vincent Snijders Relationship deleted parent of 0001121
2008-07-16 20:33 Vincent Snijders Relationship added parent of 0011121
2008-07-16 20:35 Vincent Snijders Relationship added parent of 0000964
2008-07-16 20:35 Vincent Snijders Relationship added parent of 0000974
2008-07-16 20:36 Vincent Snijders Relationship added parent of 0001928
2008-07-16 20:36 Vincent Snijders Relationship added parent of 0007717
2008-07-16 20:36 Vincent Snijders Relationship added parent of 0007828
2008-07-16 20:37 Vincent Snijders Relationship added parent of 0008853
2008-07-16 20:37 Vincent Snijders Relationship added parent of 0009273
2008-07-16 20:37 Vincent Snijders Relationship added parent of 0009293
2008-07-16 20:37 Vincent Snijders Relationship added parent of 0009303
2008-07-16 20:38 Vincent Snijders Relationship added parent of 0010668
2008-07-16 20:38 Vincent Snijders Relationship added parent of 0009568
2008-07-16 21:34 Vincent Snijders Relationship added parent of 0010680
2008-07-16 22:17 Vincent Snijders Relationship added parent of 0011007
2008-07-16 22:24 Ales Katona Relationship deleted has duplicate 0011669
2008-08-21 08:22 Vincent Snijders Relationship added parent of 0011935
2008-09-07 09:30 Vincent Snijders Relationship added has duplicate 0012089
2008-09-28 20:28 Vincent Snijders Relationship added parent of 0012247
2008-10-08 10:55 Vincent Snijders Relationship added parent of 0012315
2008-10-08 10:55 Vincent Snijders Relationship added parent of 0012314
2008-10-13 13:06 Vincent Snijders Relationship added parent of 0012324
2008-10-17 22:06 Vincent Snijders Relationship added parent of 0012396
2009-01-19 14:09 Vincent Snijders Relationship added parent of 0012952
2009-04-22 21:27 Vincent Snijders LazTarget 1.2 => 0.9.28
2009-04-22 21:28 Vincent Snijders Target Version => 0.9.28
2009-07-23 23:41 Martin Friebe Relationship added parent of 0012460
2009-09-27 11:20 Vincent Snijders Status assigned => resolved
2009-09-27 11:20 Vincent Snijders Fixed in Version => 0.9.27 (SVN)
2009-09-27 11:20 Vincent Snijders Resolution open => fixed
2009-09-27 11:20 Vincent Snijders Note Added: 0031000
2011-12-01 11:22 Marc Weustink Status resolved => closed